3

I want to create a .bbl file with bibitems to be able to use it with bibentry package. Below is a single example how I'm doing this:

\begin{thebibliography}{1}

\bibitem{ABC} Author Name {\em Title} 2016.

\end{the bibliography}

In my testFile.tex file I attached the testFile.bbl file as follows:

\documentclass{article}
\usepackage{bibentry}

\begin{document}
 \input{testFile.bbl}
 \bibliographystyle{alpha}
 \nobibliography{testFile}

 My citation: \cite{ABC}
\end{document}

However, when I run my .tex file I obtain the following error:

Lonely \item--perhaps a missing list environment. 

I checked that solution latex error lonely item--perhaps a missing list environment in the bibliography , but it is not working unfortunately. I'm using TexShop for Mac's, however I tried also to compile via terminal and the error was the same. Can anyone suggest what I might be doing wrong?

7
  • I am a bit confused by the appearance of bibliographystyle and nobiliography in your code. Why is it in there?
    – Johannes_B
    Jun 23, 2016 at 12:36
  • @Johannes_B nobiliography is because even if I want to cite, I don't want to have the list of references at the end of the file. bibliography style is to define the style, shouldn't it be there?
    – Ziva
    Jun 23, 2016 at 12:47
  • The \nobibliography{testFile} in not needed, beside this your example works fine. Are you sure that you are really running exactly what you are showing? And how is the name of your main document? Can you show the log-file? Jun 23, 2016 at 12:50
  • @The name of my main document is the same as the bibliography file (testFile.tex)
    – Ziva
    Jun 23, 2016 at 12:52
  • 1
    I ran into the same problem by switching from an old working latex source to xelatex. Are you by any chance running xelatex? Mar 11, 2019 at 9:50

1 Answer 1

0

Using

\usepackage{bibentry}
\usepackage[square,sort,comma,numbers]{natbib}

instead of just

\usepackage{bibentry}

fixed the Lonely \item--perhaps a missing list environment error in the auto-generated .bbl file when using the \nobibliography{testFile} option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.