I am using biblatex/biber and have - among books and articles for which i use several bibliographies - the document type "misc", which I use for legal documents.

I am trying to implement a specific citing style for these documents, which roughly follows the following logic: "Court v. dd.mm.year, ...decision name and number".

Since I want to keep it simple and always \fullcite these cases, my idea was to simply add the "v. dd.mm." to the author by hand and only include the year in the year field. This way biblatex can sort the judgements by year without much further need to redefine the misc-type, apart for removing the parenthesis around the "year" and removing the space between the author and the year.

I have trouble implementing this last single point of my idea, as can be seen in the following picture - there is space between the "author v. dd.mm." and "year", which I would like to remove.

enter image description here

I tried my best to resolve this problem, but get an nameyeardelim undefined error. Any ideas how to solve this?


\usepackage[autocite=footnote, maxcitenames=3, language=german, style=authoryear-ibid, backend=biber, sorting=nyt]{biblatex}



\printbibliography[title={Europ\"aischen Union Rechtsakte}, type=misc]

My lit.bib:

    Author = {{EuG~v.~15.6.}},
    Date-Added = {2016-06-13 14:46:17 +0000},
    Date-Modified = {2016-06-13 14:46:45 +0000},
    Howpublished = {Rs. T-298/07, T-312/97, Slg. 2000, II-2325 -- Alzetta},
    Year = {2000}}

Biblatex 3.4 introduces new commands to define "delimiters" and these are context dependent.

The format of a delimiter is defined by the command


The context can be used to indicate where the delimiter is used (bibliography, citation, in text citation and so on, and it is possible to defined new contexts).

For the specific case so we can use


The first definition is to change the appearance in citation, the second one use the bib option. The bib option is used for the environment created by \printbibliography and when a bib driver is used.

With the addition above the MWE (with an additional bib entry to illustrate the difference) produces

enter image description here

  • So I tried to modify your general example according to what I need it to look like, as described in my original post and, accordingly, red the "renewcommand"-command. Since I have several bibliographies, the context needs to be the misc type and no delimiter between author and year: "\DeclareDelimFormat[misc]{nameyeardelim}{}". This does not work, I get an "undefined control sequence" error. – kuuhkuuh Jun 23 '16 at 22:54
  • 1
    yes. I get "undefined control sequence" errors for all of these. But I am also not sure as to how to exactly implement your suggestions. – kuuhkuuh Jun 25 '16 at 11:08
  • 1
    So, it seems you have a version of bib latex older than 3.4. You might consider to update – Guido Jun 25 '16 at 11:24
  • Woohoo, you are right! It works now. Update my MacTex Version and it seems to work. – kuuhkuuh Jun 25 '16 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.