2

I am having trouble getting "jump to source" working properly with my new TeX set-up on my new computer.

I installed WinEdt 10 with MikTex 2.9 on a new Windows 10 computer. I use pdftexify, and the default pdf viewer was TeXworks, which is fine with me, although I've not used it before. The synctex file seems to be generated properly, but when I use "jump to source" while viewing my pdf file in TeXworks, it jumps to the source in the TeXworks editor, rather than in the WinEdt, which is what I want. I don't see in the TeXworks preferences how to tell TeXworks to use the WinEdt editor. Could you help?

Incidentally, my inverse search didn't work at all with "synctex=-1" but rather I had to change to "synctex=1" in the WinEdt execution mode switch setting, in order at least for TeXworks to jump to source with its own editor.

  • 1
    For a workaround, I simply avoid TeXworks. Instead, I have now installed Sumatra, and that works fine with inverse search to WinEdt. But let me leave this question, since I would like to know how to do it. I find it odd that the default new set-up with WinEdt didn't work for me as expected. – JDH Jun 25 '16 at 13:52
1

I use WinEdt, and here is what works for me:

"C:\Program Files\WinEdt Team\WinEdt 10\WinEdt.exe" "[Open(|%f|);SelPar(%l,10);]"

In Sumatra click Menu/Settings/Options, then in the last box on that dialog box copy and paste the above.

  • Yes, I've said that it works fine with Sumatra, and the default setting when I installed it (which is almost the same as what you have), works perfectly. My question was about how to do this with the TeXworks viewer, rather than Sumatra. – JDH Jul 2 '16 at 10:36
1

I had the same problem using thee previewer YAP. To fix this, I did the following:

View > Options > Inverse DVI Search.

Here, there was a list of programs YAP used for the inverse search. And indeed the only program in the list that appears was WinEdt. But, there was a "Command line" box that was empty, and was filled when I double-clicked the WinEdt option.

After this, my problem was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.