4

I'm using the ConTeXt's letter module with the french style but I don't want the date do appear. I tried to setup an empty list of elements to display but it didn't work,

\setupletter
    [list={}]

Edit:

The following version has the date. But if I change the style to knuth the date disappears.

\usemodule[letter][style=french]

\starttext

\setupletter
  [fromname={Your Name},
   fromaddress={Street\\Town},
   fromphone={Phone}]

\setupletter
  [list={}]

\setupletter
  [subject={Subject}]

\setupletter
  [toname={Addressee},
   toaddress={Street\\Town}]

\startletter
  [opening={Dear Reader},
   closing={Sincerely,},
   signature={Signature}]


\stopletter

\stoptext
1
  • 2
    I think we need a full minimal example (also, are we talking Mark II or Mark IV?).
    – Joseph Wright
    Commented Oct 15, 2011 at 18:48

1 Answer 1

4

(Based on information from Wolfgang Schuster, author of the letter module.)

To remove the date you can use

\setupletterstyle
  [location]
  [alternative=none]

leading to a full minimal example

\usemodule[letter][style=french]

\setupletter
  [fromname={Your Name},
   fromaddress={Street\\Town},
   fromphone={Phone}]

\setupletterstyle
  [location]
  [alternative=none]

\setupletter
  [subject={Subject}]

\setupletter
  [toname={Addressee},
   toaddress={Street\\Town}]

\startletter
  [opening={Dear Reader},
   closing={Sincerely,},
   signature={Signature}]

\input knuth

\stopletter

(You don’t even need \starttext here because it’s already part of \startletter)

Using the list setting does not work because in the french style the location block is used to place the date and not the reference block as used in the other styles.

Wolfgang also says

The knuth isn’t a solution for the problem because it’s none of the official styles and I use it only for a gimmick of the module where you can use the commands from the letter code in The TeXbook.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .