1

I am using TeXmaker on a Mac running ElCapitan. My copy of TeXmaker worked just fine until I decided to reinstall it. Now, it fails to compile documents with pdflatex. It used to compile normally, but now the compiling procedure hangs with "Process Started" in the Messages/Log window and it displays "/Library/TeX/texbin/pdflatex" at the bottom of the principal window (cf. Picture 1).

Picture 1

The code used for instance is:

\documentclass[a4paper, 11pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[french]{babel}

\begin{document}

This is a test

\end{document}

Note that I am using MacTex 2016 and that I changed the paths in what I believe is the correct way for ElCapitan in the TeXmaker preferences (cf. Picture 2).

Picture 2

Thank you in advance for your help, Arnaud.

5
  • The setting for latex is wrong. It should be /Library/TeX/texbin/latex. Are you sure you are using pdflatex rather than latex? What does which pdflatex return when run in Terminal? Jul 12 '16 at 16:42
  • Hi @HerbSchulz , thank you. When I run which pdflatex it returns /Library/TeX/texbin/pdflatex. I changed the path for LaTeX but it did not solve the problem.
    – Nano
    Jul 18 '16 at 12:04
  • could you open the file in TeXShop (it's in /Applications/TeX) and see that it type sets there? Jul 18 '16 at 15:36
  • @HerbSchulz, TeXShop works well for me. The path for (pdf) TeX & dvips is /Library/TeX/texbin.
    – Nano
    Jul 19 '16 at 10:01
  • I'm not a user of TeXmaker but I've seen mention of a Quick Compile. Does that feature use latexmk? If so there may be a problem with the latexmk preference or arguments. Jul 19 '16 at 15:07
1

To be honest, it is very difficult to answer depending on such limited information. You may try your luck with the following. It may be the case that some of packages included in the preamble may not be available. If you are on Proxy internet connection (Eg.: University, Company etc.) You can open your MiKTeX Console (or any equivalent one on your PC). Click "Settings" on left pane. From drop-down menu of "Packages are installed from", click "Change", go to Connection Settings and change/update your internet proxy settings. Make sure you check "Authentication required" if needed. Click "Next" and put in your internet access login credentials if prompted. Choose any server to download packages and click "Finish". Now make sure you have the "Always install missing packages on the fly" radio button. Go back to your TexStudio window and Compile (F5). Hopefully it works. If some packages are missing, they will be installed and then the compilation goes through.

If the problem persists, In the top toolbar of Texstudio go to “Options” -- “Configure Texstudio” -- Build.

Change the default compiler (to say, XeLatex) and try the following. If the following steps do not work, change the default compiler and try again. More like trial and error.

You may get a error showing the names of the missing packages. You may consider installing them manually and try again.

You may see the screenshots as a reference, although not on macOS. https://imgur.com/a/J9bpyRE

0

This may help someone:

In my case the event log got stuck at this point:

INFO  miktex-xelatex - this process (6743) started by 'texstudio' with command line: /Users/username/bin/miktex-xelatex
INFO  miktex-xelatex - allowing known shell commands
INFO  miktex-xelatex - enabling input (output) from (to) processes

Even after waiting for long, nothing happened after this.

When I checked my "Configure TexStudio" settings, they were like so: enter image description here

Then I changed it to the following: (check the Latex, Pdflatex, Xelatex commands) enter image description here (could be done easily by clicking the button circled in red above)

And voila! Things then worked normally!

The problem was with correctly formatting the commands and including filenames.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.