0

I've tried to use MakeIndex with the spanish package babel. I want to add to the index some words witch are written in the Introduccion, that is numbered with roman numbers in Small Caps. But in this situation MakeIndex rejects these words. I've read that it needs the numbers of the pages to be in lowercase, but it is an error in the Spanish language.

I've tried with es-preindex as an option in babel (as you can see here, page 4) but nothing changes.

Does anybody know how to get the words in the index and the roman numbers in small caps? Thanks in advance.

EXAMPLE:

\documentclass[a4paper,openright,10pt]{book}
\usepackage[spanish,es-nosectiondot,es-noquoting]{babel}
\usepackage{makeidx}
\makeindex

\title{Bla bla bla }

\author{Me}

\begin{document}

\frontmatter
\maketitle


\chapter{Introduction}

Bla blaaaa blaaa blaaa blaa \index{blaa} .....

\mainmatter

\chapter{Blaaaaaaaaaaaa}

Heloooooooo its meeeee \index{meeeee}.

\renewcommand{\indexname}{\'{I}ndice de Materias}

\printindex


\end{document}

And the result is:

The "blaa" isn't shown!

By adding "es-preindex" in the babel package, the result is exactlly the same.

  • makeindex cannot process complex page numbers (at least not without a lot of tricks) – user31729 Jul 1 '16 at 22:39
  • Maybe try with imakeidx and xindy? – Bernard Jul 1 '16 at 22:43
  • I have read about xindy, but I wondered if there's any "trick". I still don't know why es-preindex doesn't work (it seems an very easy "trick"). – Minkowski Jul 1 '16 at 22:51
  • Please, provide a MWE. – Javier Bezos Jul 2 '16 at 9:56
  • I have just added an example. As you can see the "blaaa" in the introduction is not shown in the index. – Minkowski Jul 2 '16 at 10:30
3

With the package option es-preindex the .idx is pre-processed to generate a new file with extension .eix, with the problematic entries fixed. The .eix is the file you must process with makeindex, not the .idx. If you are writing Spanish documents, you may want to have a look at esindex, too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.