13

I have a .bib file with reference. But when i click on [1] it does not take me to the reference page ? I also want the blue box around it. I dunno what settings to type. And my reference not citing in order. Like I have this

@CONFERENCE{Dalal,
  author = {N. Dalal and B. Triggs},
  title = {Histograms of oriented gradients for human detection},
  booktitle = {Computer Vision and Pattern Recognition},
  year = {2005}
}

@CONFERENCE{1997Merlino,
  author = {P.Dollar, R.Appel, S.Belongie and P.Perona},
  title = {Fast feature pyramids for object detection},
  booktitle = {TPAMI},
  year = {2014}
}

but when i cite Dalal 1st it prints [2] instead of [1]. And also i edit bib but latex not updating the citation. My bib not updating because after i edit all my citation lost. Help thanks

7
  • 6
    Add \usepackage{hyperref} to your preamble -- and read the hyperref manual!
    – user30471
    Commented Jul 4, 2016 at 15:15
  • 1
    ok but now all my content page got red boxes
    – Kong
    Commented Jul 4, 2016 at 15:31
  • For question marks, it's a common question related to compilation look here, as for the red box, to disable it you need to load the package with an option: \usepackage[hidelinks]{hyperref} look here, you may want to set url color to blue urlcolor=blue.
    – Cfun
    Commented Jul 4, 2016 at 16:43
  • For the order how citations are named it depends on the style you are using, which you didnt specify here. \bibliographystyle{comes here} unless you are using the one by default.
    – Cfun
    Commented Jul 4, 2016 at 16:52
  • Thanks all ! The suggestions you all posted have helped me fix all my problems !
    – Kong
    Commented Jul 4, 2016 at 17:00

1 Answer 1

25

Firstable you must include \usepackage{hyperref} in your preamble, about question marks, it's a common question which is related to compilation, you have to use a compilation chain like mentionned in this answer.

About the red box mentionned in the comment, to hide/disable it, you need to load the hyperref package with the option hidelinks this way \usepackage[hidelinks]{hyperref} (also it's a common question). You may want to set url color to blue using the option urlcolor=blue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .