1

My table of contents in beamer is empty, I got 4 sections and 3 subsections, but no one of them appears in my table of contents. Here is my code :

\documentclass[smaller,t]{beamer}
\usepackage[frenchb]{babel}
\frenchbsetup{option1=false,option2=true,option3=false}
\usepackage{media9}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{subcaption} 
\usepackage{amssymb}
\newcommand{\includemovie}[4]        {\includemedia[width=#1,height=#2,activate=pageopen,addresource=#3,flashvars={src=#3&loop=true&controlBarAutoHide=false}]{#4}{StrobeMediaPlayback.swf}}
\usepackage{amsmath}
\usepackage{color}
\usepackage{isomath}
\usepackage{bm}
\usepackage{stmaryrd}
\usepackage[mathscr]{euscript}
{
\usetheme[width=1.5cm]{Berkeley}
\usecolortheme{beaver}
\usefonttheme{professionalfonts}
\setbeamertemplate{navigation symbols}{}
\setbeamertemplate{caption}{\raggedright\insertcaption\par}
\setbeamercovered{transparent}  
}
\setbeamertemplate{sidebar right}{} 
\setbeamertemplate{footline}[frame number]
\begin{document}
\begin{frame} % premier transparent 
\frametitle{Plan de présentation}
\tableofcontents
\end{frame}
\section{Problématique}
\begin{frame}
\frametitle{Contexte industriel}
\end{frame}
\end{document}
  • You have a {....} pair around most of your beamer related settings. And the font color is white and hard to detect. Correct the \frenchbsetup command too, please – user31729 Jul 11 '16 at 15:56
1

The code

{
\usetheme[width=1.5cm]{Berkeley}
\usecolortheme{beamer}
\usefonttheme{professionalfonts}
\setbeamertemplate{navigation symbols}{}
\setbeamertemplate{caption}{\raggedright\insertcaption\par}
\setbeamercovered{transparent}  
}

is effectively useless all settings occur within a {...} group, i.e. the settings do not survive after the end of the group.

Omitting the {...} pair, the \tableofcontents appears in the sidebar, however, the colortheme is very inconvenient for this!

\documentclass[smaller,t]{beamer}
\usepackage[frenchb]{babel}
%\frenchbsetup{option1=false,option2=true,option3=false}
\usepackage{media9}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage{subcaption} 
\usepackage{amssymb}
\usepackage{amsmath}
\usepackage{color}
\usepackage{isomath}
\usepackage{bm}
\usepackage{stmaryrd}
\usepackage[mathscr]{euscript}

\newcommand{\includemovie}[4]        {\includemedia[width=#1,height=#2,activate=pageopen,addresource=#3,flashvars={src=#3&loop=true&controlBarAutoHide=false}]{#4}{StrobeMediaPlayback.swf}}

\usetheme[width=1.5cm]{Berkeley}
\usecolortheme{crane}
%\usecolortheme{beaver}% hard to see!
\usefonttheme{professionalfonts}
\setbeamertemplate{navigation symbols}{}
\setbeamertemplate{caption}{\raggedright\insertcaption\par}
\setbeamercovered{transparent}  

\setbeamertemplate{sidebar right}{} 
\setbeamertemplate{footline}[frame number]
\begin{document}
\begin{frame}{Plan de présentation} % premier transparent 
%\frametitle{Plan de présentation}
\tableofcontents[currentsection]
\end{frame}
\section{Problématique}
\begin{frame}{Contexte industriel}
\end{frame}
\section{Et maintenant}
\begin{frame}{Des baguettes}

\begin{center}
\includegraphics[scale=0.3]{Nl-baguettes2.jpg}
\captionof{figure}{Nom nom nom}
\end{center}
Source: \url{CC BY-SA 3.0, https://commons.wikimedia.org/w/index.php?curid=422101}
\end{frame}

\end{document}

enter image description here

  • I have corrected this first part, but I still have an empty table of contents with only the title "Plan de présentation" – Abdallah Jul 11 '16 at 16:08
  • @Abdallah: Did you compile (at least) twice? – user31729 Jul 11 '16 at 16:10
  • Yes, very strange I am compiling with xelatex – Abdallah Jul 11 '16 at 16:16
  • @Abdallah: I've recompiled with xelatex (I have to remove inputenc of course), but I still get the ToC – user31729 Jul 11 '16 at 16:54
  • Please see the link – Abdallah Jul 11 '16 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.