I have a document in B5 format. Originally it was "twoside" with different margins on odd and even pages. Now I want it with same margins, so I tried to delete the command "twoside" but blank pages are not added anymore at the chapters' end.

How can I solve this problem? Thank you


\usepackage[b5paper, total={5in, 8in}]{geometry}



\clearpage \input{acknowledgements.tex}     \cleardoublepage
\clearpage \input{Preface.tex}  \cleardoublepage


\clearpage \input{Introduction.tex}         \cleardoublepage 
\clearpage \input{Ch_2.tex}         

The psd_thesis.cls is reported below:





\renewcommand{\baselinestretch}{1.5}  % Double-spaced

\usepackage[round]{natbib}  % bib style

%\usepackage[tx]{sfmath}      % a package of fonts
%\usepackage{helvet}             % For Helvetica (Arial is just a bad copy of Helvetica)

\vspace*{50\p@}%  {\parindent \z@ \raggedright \normalfont
\ifnum \c@secnumdepth >\m@ne
\large \scshape \bfseries \@chapapp\space \thechapter
\vskip 20\p@
\large \bfseries #1\par\nobreak
\vskip 40\p@  }}

\vspace*{50\p@}%{\parindent \z@ \raggedright
\large \scshape \bfseries  #1\par\nobreak
\vskip 40\p@  }}  

\renewcommand{\section}{\@startsection{section}% % the name{1}% % the level{0mm}% % the indent{3.0\baselineskip}% % the before skip{2.5\baselineskip}%    % the after skip{\normalfont \normalsize}} % the style

\renewcommand{\subsection}{\@startsection{subsection}% % the name
{2}% % the level{0mm}% % the indent{-\baselineskip}% % the before  skip{1.5\baselineskip}% % the after skip{\normalfont \normalsize}} % the style

  • 1
    Please provide a compilable document, not something with a bunch of \input statements nobody can use (apart from you) – user31729 Jul 11 '16 at 18:01
  • try openright as an option to your document class. (Just random guessing; I don't know the psd_thesis class at all.) – Willie Wong Jul 11 '16 at 18:11
  • twoside is for printing on both sides of a page. So, when the report is open, you see text on a left hand page and text on a right hand page. Without twoside, your document (presumably) is in oneside mode, that means, when the report is open, only the right hand pages have text. All left hand pages are completely empty and aren't numbered. – Johannes_B Jul 11 '16 at 19:57
  • If you want to change the margins, package geometry would be best way to do it. – Johannes_B Jul 11 '16 at 19:57
  • @ChristianHupfer general input like '\chapter{TITLE CHAPTER 1} \label{chap:Ch_01} text text text text text text text text text text text....' work – Luca Jul 11 '16 at 20:45

B5 paper at twelve point size with enlarged leading is a guarantee for bad typesetting and, indeed, the result is among the worst I've seen. Anyway, if you have to use a class, why bother with changing its setup?


\linespread{1.5}\selectfont % the class does the wrong thing












enter image description here

  • what does the command "\linespread{1.5}\selectfont" do? Thank you – Luca Jul 11 '16 at 22:14
  • @Luca Almost the same as \renewcommand{\baselinestretch}{1.5}, but with \selectfont the increased leading is made known to geometry for a correct computation of heightrounded. – egreg Jul 11 '16 at 22:17
  • Thank you. I reported the rest of the preamble. I would like to ask you if there is in your opinion any compatibility problem with your solution. Thank you very much. I'm sorry, I'm almost new with Latex. – Luca Jul 11 '16 at 22:25
  • I tried your solution but it doesn't work. Then I tried using "oneside" and "\newpage{\blankpage}" at the beginning of every chapter, abstract etc in order to have a blank page, but the problem is that the page counter starts from the second page after the title page. Do you have suggestions? Thank you again – Luca Jul 11 '16 at 22:34
  • @Luca The openright option was missing – egreg Jul 11 '16 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.