3

I'm using this Latex document class (that's the class used for the CHI/TEI conferences) and I'm facing a strange problem with automatic newlines with words having apostrophes: in Italian we are used to have words like l'albero or l'informazione.

Unfortunately, it looks like whenever Latex (pdflatex, most recent texlive) encounter one of those words, it's not able to line break within that word which then overflows the column space.

enter image description here

Example document showing such problem here.

Any kind of help appreciated.

  • 1
    If you're already using babel, check whether your log file says something about "Italian" and hyphenation patterns; such problems can happen with MiKTeX up to version 2.8 – egreg Oct 18 '11 at 12:46
7

Load babel with the italian option to get proper hyphenation. Load it like \usepackage[italian]{babel}

  • Thanks.. this fixed the problem in the example I provided. However, when placing a citation with \cite{sachs01} I get Use of \@citex doesn't match its definition any idea??? – Fabio Varesano Oct 18 '11 at 13:09
  • babel is very picky about when it is loaded with respect to other packages, as is hyperref. You should load babel as early as possible. – Roelof Spijker Oct 18 '11 at 13:12
  • No matter where I place babel, that error is always there. Looks like a conflict with the class I'm using. Any idea?? – Fabio Varesano Oct 18 '11 at 13:15
  • 2
    I had a look in the class file, I removed the , from {\@tempswafalse\@citex,[]}% was ; Gerry 2/24/00 on line 1349. Works for me now, not really sure why there would be a , there... – Roelof Spijker Oct 18 '11 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.