3

I'm a newbie trying to write a tufte-handout including references. My file compiles fine; however, the references do not appear in the text or the margin (MWE):

\documentclass{tufte-handout}
\begin{document}
\cite{Holton2009}
\bibliographystyle{dcu}
\bibliography{Literatur}
\end{document}

What I've tried so far: looking at this (I wouldn't mind citations in the text instead of in the margins) How to remove sidenote citations in Tufte-LaTeX I replaced

\documentclass{tufte-handout}

with

\documentclass[nobib]{tufte-handout}

but I did not notice any difference between the two. Also, I tried this Citations using biblatex together with Tufte style are producing weird results but it gives me an error ('command \bibhang already defined' (?)). Lastly, after having read Tufte-book with standard natbib style author-year citations I used the [nobib] variance and added

\usepackage{natbib}

but again, that did not work.

  • How exactly do the references not appear in the document? Do you get question marks, just bold keys, nothing? Did you run BibTeX on your file? Do you get any errors or warnings in the .log and .blg files? – moewe Aug 11 '16 at 8:09
  • In the pdf, I get nothing/blanks, just a small "1" for the number of the sidenote. I did run BibTex (latex -- bibtex -- latex -- latex), and there are no warnings or errors in the .blg file. But I do get a few warnings in the .log file (I paste all of them below, just in case I've overlooked something): Package hyperref Warning: Option 'pagecolor' is not available anymore. LaTeX Warning: Unused global option(s): [nobib]. LaTeX Warning: Marginpar on page 1 moved. – NCH32 Aug 12 '16 at 17:26
  • Mhhh with your MWE I also get other errors (\harvardand) not defined, that makes me think that the style dcu may need another bibliographyy package than the one loaded by the tufte classes. – moewe Aug 13 '16 at 6:31
  • Bingo! I tried the plain style and now the reference appears :-) Can I mark your comment as an answer, somehow? – NCH32 Aug 13 '16 at 13:27
1

The style dcu.bst does not play nicely with the bibliography settings of the tufte classes. If you use a different style, things work more smoothly.

Use, for example, \bibliographystyle{plain}.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.