1

I use Texmaker and I used the assistant to start a new document. There I can choose some options, including a babel-package. I chose german, but when I compile the document, the compiler says

"Unknown option 'german'. Either you misspelled it (babel) or the language definition file german.ldf was not found".

I searched some internet platforms and documentations but didn't find an answer to my specific problem. Does anyone have an idea how to solve this problem? Is there a possibility to install the german-package separately and if there is, how do I do it?

  • 1
    Welcome to TeX SX! What is your distribution? – Bernard Jul 16 '16 at 13:22
  • you need to have either TeX Live, MiKTeX or MacTeX installed on your computer depending on your operating system. TeXmaker is only the frontend/editor/IDE. – naphaneal Jul 16 '16 at 13:52
  • It is more likely that you want to try ngerman once the files are properly set up. – Johannes_B Jul 16 '16 at 15:43
  • Thank you all for the quick responses. I know about ngerman, for some reason, Texmaker itself suggested the old german package. But it made no difference, both give the same problem. I'm not sure, how to find out, what distribution I have, but my operating system is Ubuntu 14.04. – Kathi Jul 17 '16 at 11:38
2

Some time ago, babel was split up in the base package and the languages. Thus, you need to install babel-german (distribution package name in TeX Live or MiKTeX).

BTW, the option name for the German language after the orthography reform of 1996 is now ngerman. ngerman.ldf is also part of the distribution package babel-german.

  • How do I install that package? Can I just tell the computer to install it in the console, or do I have to go to a specific location in the program folder? – Kathi Jul 17 '16 at 11:41
  • @Kathi Both TeX Live and MiKTeX come with documentation. Or if you had installed a different TeX distribution, that will also have some documentation very likely. – Heiko Oberdiek Jul 17 '16 at 11:50
  • So, I found out, that I have TeX Live (it was already installed with my ubuntu version, so I only installed Texmaker). I looked through the documentation and I came across the package manager tlmgr. But when I tried to run some test commands I always get "cannot setup TLPDB in /home/kathi/texmf at /usr/bin/tlmgr line 5336.". I also tried to simply install babel-german and my computer said that the package couldn't be found. I am not sure if this is a TeX-problem anymore or rather a Unix problem. – Kathi Jul 17 '16 at 13:06
  • 1
    @Kathi According to How to install a language package in Texmaker on Ubuntu 12.04? the solution would be: $ sudo apt-get install texlive-lang-german – Heiko Oberdiek Jul 17 '16 at 14:02
  • I did install the package you mentioned using synaptic, which I found out is very helpful when searching for some package without exactly knowing the name. (A friend called coincidentally and told me just before I read your answer) So problem solved now, thank you! – Kathi Jul 17 '16 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.