1

I'm using ctable package for tables with footnotes. IMO it looks better than using booktabs with threeparttable package. I also use pgfplots (which I guess uses tikz package, in turn). Everything works perfectly. Problem is that ctable throws a warning:

Package ctable Warning:  Transparency disabled: incompatible with tikz package on input line 5.

MWE:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{pgfplots}
\usepackage{ctable}
\begin{document}
Content here.
\end{document}

I doesn't seem to affect anything and my PDF looks fine.

Q: Is there any simple way to disable the warning? I'm using Overleaf.

Or can I disable ctable transparency feature? Are there other possible alternatives or should I just live with the warning.

2

Yes. You asked to surpess the warning. I am not sure if you really want to have this solution.

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{silence}
\WarningFilter{ctable}{Transparency disabled:}
\usepackage{pgfplots}
\usepackage{ctable}
\begin{document}
Content here.
\end{document}

It only surpress the warning. A bugreport has been sent to the maintainer a few minutes ago...

  • Thanks! This is what I needed. Not that this is the optimal solution but it will suffice until the transparency/incompatibility issue is properly resolved. And thanks for sending the bug report. I hope ctable is still maintained. Or some other package gets better support for table footnotes. – Paapaa Jul 17 '16 at 15:38
  • I got response from the maintainer and he will send a notification if the problem is resolved. – Peter Ebelsberger Jul 17 '16 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.