2

I've been using TexMaker and MikTex under Windows10 for 3-4 months and I managed to convert the short .odt thesis I wanted to submit into a .tex file. For the bibliography, I used Jabref and BibTex.

Now I've considered making the transition to BibLaTex with Biber for a new work requiring the use of Unicode for the bibliography.

However I get an issue which doesn't seem related to the use of Unicode since it persists even with a minimal code. My minimal .tex file is as follows:

\documentclass[a4paper,12pt]{report}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[american]{babel}

\usepackage[backend=biber]{biblatex}
\addbibresource{Biblioessai.bib}

\begin{document}
\autocite{Bau2003}
\printbibliography
\end{document}

My .bib file is the following:

% Encoding: UTF-8

@Book{Bau2003,
title     = {Dictionnaire persan-français, français-persan ordre latin},
publisher = {La Maison du dictionnaire},
year      = {2003},
author    = {Bau, Pierre and Lazard, Gilbert},
address   = {Paris},
isbn      = {2-85608-177-0},
pages     = {1 vol. (XXV-533 p.)},
url       = {http://www.sudoc.fr/075605902},
}

I've configured TexMaker with "biber %" under the Bib(La)Tex field and tried to run multiple times PdfLaTex and Bib(La)Tex alternatively, but it always gives me the following error message:

Process started

lib.pm did not return a true value at -e line 165.

Process exited with error(s)

The .pdf file I get is a one page document containing only "[Bau2003]" on the top; the bibliography doesn't appear. (I feel it may be an unrelated issue but after searching for the whole afternoon I'm a bit confused...)

Thanks a lot

  • Can you show us the .blg file? Even though the pages field is malformed as noted by Bernard below, that should not leas to such an error? Can you update Biber (and then also biblatex with it) using MikTeX's Updater (in both Admin and User mode, you might have to run the Updaters twice)? Can you run biber --version on the command line? If so, what is the output? – moewe Jul 18 '16 at 18:43
  • @moewe oooooh you're right!! no .blg file has appeared! I'll search how to update Biber! – Stanin Jul 18 '16 at 20:15
  • Thank you sooo much!!! I uninstalled then reinstalled BibLaTex through MikTex Package Manager, and Biber through the file biber.exe in C:/Program Files (x86)/MiKTeX 2.9/miktex/bin/ It works now! – Stanin Jul 18 '16 at 23:57
  • If that implies that you installed Biber manually and not via the Package Manager, please consider removing the manual install and install Biber using the Package Manager. That way you can be sure that your versions of Biber and biblatex match. Make sure to run the Updaters after that. – moewe Jul 19 '16 at 7:18
2

There's a small problem with the pagesfields, which is not relevant (should be pagetotal. Mentioning the number of volumes with the volumes field works only with several volumes (you obtain vols 1…), so I used the note field.

That said, this code compiles for me:

\documentclass[a4paper,12pt]{report}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern} %
\usepackage{filecontents}
\begin{filecontents}{Biblioessai.bib}
@Book{Bau2003,
title = {Dictionnaire persan-français, français-persan ordre latin},
publisher = {La Maison du dictionnaire},
year = {2003},
author = {Bau, Pierre and Lazard, Gilbert},
address = {Paris},
isbn = {2-85608-177-0},
pagetotal = {(xxv  + 533 p.)},
note={1 vol.},
url = {http://www.sudoc.fr/075605902},
}
\end{filecontents}}


\usepackage[american]{babel}

\usepackage[backend=biber]{biblatex}
\addbibresource{Biblioessai.bib}

\begin{document}

\autocite{Bau2003}
\printbibliography

\end{document} 

enter image description here

  • If the information that the book constitutes of one volume is important at all, it could be moved to the volumes field. I also would not include the brackets in the pagetotal field, that is something that should be left to the style. If + is declared a NumChar the automatic page numbering will then even work. (pagetotal = {xxv + 533}, volumes = {1},) – moewe Jul 18 '16 at 18:52
  • @moewe: That's what I tried first, but biblatex uses the plural (1 vols)… For the parentheses, it's traditional in French typography, as far as I know. How does one declare + a NumChar? I don't know this procedure… – Bernard Jul 18 '16 at 19:04
  • Ah yes, I should have seen the s. (Obviously PL thought it wouldn't make sense to have volumes = {1}; one could change that of course to detect if singular is needed.) \DeclareNumChars seems to be the command to make characters NumChars ... If brackets are traditional in French typography we probably just need \DeclareFieldFormat{pagetotal}{\mkbibparens{\mkpagetotal[bookpagination]{#1}}} and can still get rid of the brackets in the .bib file (what if you decide it isn't tradition after all, or you want to follow a language with different traditions?) – moewe Jul 18 '16 at 19:08
  • @Moewe: Yes, it makes sense. At least, I've often seen it in (French) antique booksellers' catalogues. For the brackets, I can patch specifically for the French language, but it would be better to have as an option, in my opinion. – Bernard Jul 18 '16 at 19:14
  • I've been found out ^^ yep I'm writing in French! Thank you Bernard for your fast answer, I've tried but it doesn't seem to work for me, the same error message appears; as moewe pointed out above, it may have something to do with Biber – Stanin Jul 18 '16 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.