2

I always get annoying warnings when using arsclassica package.

This is a MWE:

\documentclass{scrreprt} % KOMA class
\usepackage{arsclassica} % improve classicthesis
\usepackage[english]{babel}
\usepackage{lipsum}

\title{My title}
\author{Myself}

\begin{document}
\maketitle
\chapter{Introduction}
\lipsum
\end{document}

and the following the warnings that I get:

warning: [scrreprt] Usage of package `titlesec' together with a KOMA-Script class is not recommended. I'd suggest to use the package only if you really need it, because it breaks several KOMA-Script features, i.e., option `headings' and the extended optional argument of the section commands . Nevertheless, using requested package `titlesec'
warning: [hyperref] Option `hyperfootnotes' has already been used, setting the option has no effect
warning: [hyperref] Option `pdfpagelabels' has already been used, setting the option has no effect

Is there anyone with some idea how to fix this annoyance? After some trials it looks like it is the arsclassica package itself that is generating the warnings.

  • I would be annoyed as well, if my editor would show me the warning that way. – Johannes_B Jul 19 '16 at 10:34
  • You can silence the warnings or just ignore them. I don't know about the warning from arsclassica, but you can't simply avoid the one from classicthesis. – Johannes_B Jul 19 '16 at 10:35
2

The author of the koma-script classes has decided to issue a warning about usage of titlesec along with them.

However, you are not bound to use scrreprt and you can use book instead. You need to set the page geometry yourself, but this is already true when scrreprt is involved.

\documentclass{book}

\usepackage{arsclassica} % improve classicthesis
\usepackage[
  includehead,includefoot,
  textwidth=336pt,
  textheight=675pt,
]{geometry}

\usepackage[english]{babel}
\usepackage{lipsum}

\title{My title}
\author{Myself}

\begin{document}

\maketitle
\chapter{Introduction}
\lipsum
\end{document}

There will be another warning:

Package classicthesis Warning: Using package "footmisc" with option "flushmargin"
for footnote setup (not 100\% the same as with KOMA).

and the warnings by hyperref will still be there. There's little you can do about them: when arsclassica issues \hypersetup, the options hyperfootnotes and pdfpagelabels have already been set and they can't be repeated.

For the footmisc warning you can load scrextend (thanks to Johannes_B for the suggestion); the other two warnings can be silenced.

\documentclass{book}

\usepackage{silence}
\WarningFilter{hyperref}{Option `hyperfootnotes'}
\WarningFilter{hyperref}{Option `pdfpagelabels'}

\usepackage{scrextend}
\usepackage{arsclassica} % improve classicthesis
\usepackage[
  includehead,includefoot,
  textwidth=336pt,
  textheight=675pt,
]{geometry}

\usepackage[english]{babel}
\usepackage{lipsum}

\title{My title}
\author{Myself}

\begin{document}

\maketitle
\chapter{Introduction}
\lipsum
\end{document}

If you want to use scrreprt, you don't need scrextend and you can add the following filter:

\WarningFilter{scrreprt}{Usage of package `titlesec'}
  • @Johannes_B Nice to know. – egreg Jul 19 '16 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.