1

I would like to have the author with the multi-word last name "De Marneffe" appear under "M" instead of "D" but still read it like this: De Marneffe M, ... 2006. The full entry is:

@InProceedings{deMarneffe2006,
author =     {De Marneffe, M. and MacCartney, B. and Manning, C.},
title =      {{Generating Typed Dependency Parses from Phrase Structure Parses}},
booktitle = {Proceedings of the 5th edition of the International Conference on Language
             Resources and Evaluation (LREC '06)},
year =   {2006},
pages = {449--454},
address = {Genoa, Italy}
}

and it appears as follows:

De Marneffe M, MacCartney B, Manning C (2006) Generating Typed Dependency Parses from
Phrase Structure Parses. In: Proceedings of the 5th edition of the International
Conference on Language Resources and Evaluation (LREC ’06), Genoa, Italy, pp 449–454

(inserted newlines here for readability)

In other words, I don't want it to read "Marneffe, M. de", but as "De Marneffe, M.", and it should appear after "Lundborg", not "Chiang".

This appears as part of an article with its own style file (svjour3) and separate .bib file (in which this entry appears) which uses "spbasic".

I found a few relevant topics (searched for "multi-word last names") but none answering quite what I was looking for.

Importantly, it does not work when I simply write "Marneffe, M. de" in the BibTeX, because (1) it is cited as "Marneffe" in the text (not "De Marneffe"), and (2) it appears as "Marneffe Md" in the bibliography (instead of "De Marneffe M").

Appreciated.

1

BibTeX Solution

With \noopsort{Naurois}}{de Naurois} you can define the place where the entry should be sorted in.

\documentclass{article}

\begin{filecontents}{\jobname.bib}
@PREAMBLE{ {\providecommand{\noopsort}[1]{}} }

@MISC{
    test,
    author = {My, Test},
    title = {test},
    year = 2016
}

@ARTICLE{
    Naurois2009,
    author = {{{\noopsort{Naurois}}{de Naurois}}, M. and {Rolland}, L.},
    title = "{A High Performance Likelihood Reconstruction of {$\gamma$}-Rays for Imaging Atmospheric Cherenkov Telescopes}",
    journal = {Astroparticle Physics},
    archivePrefix = "arXiv",
    eprint = {0907.2610},
    primaryClass = "astro-ph.IM",
    year = 2009,
    month = "{Dez.}",
    volume = 32,
    pages = {231-252},
    doi = {10.1016/j.astropartphys.2009.09.001},
    adsurl = {http://adsabs.harvard.edu/abs/2009APh....32..231D},
    adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
\end{filecontents}

\usepackage{natbib}

\begin{document}

\cite{Naurois2009}
\cite{test}

\bibliographystyle{dinat}
\bibliography{\jobname}

\end{document}

enter image description here

BibLaTeX Solution

In biblatex the sortkey= {} field gives you the possibility to specify the place to sort this entry.

\documentclass{article}

\begin{filecontents}{\jobname.bib}
@MISC{
    test,
    author = {My, Test},
    title = {test},
    year = 2016
}

@ARTICLE{
    Naurois2009,
    author = {{de Naurois}, M. and {Rolland}, L.},
    sortkey= {Naurois, M. de},
    title = "{A high performance likelihood reconstruction of gamma-rays for imaging atmospheric Cherenkov telescopes}",
    journal = {Astroparticle Physics},
    archivePrefix = "arXiv",
    eprint = {0907.2610},
    primaryClass = "astro-ph.IM",
    year = 2009,
    month = dec,
    volume = 32,
    pages = {231-252},
    doi = {10.1016/j.astropartphys.2009.09.001},
    adsurl = {http://adsabs.harvard.edu/abs/2009APh....32..231D},
    adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
}
\end{filecontents}

\usepackage[style=authoryear,natbib=true]{biblatex}
\DeclareNameAlias{author}{last-first}
\bibliography{\jobname}

\begin{document}

\cite{Naurois2009}
\cite{test}

\printbibliography

\end{document}

enter image description here

  • Thank you very much for your detailed reply samcarter. I will most definitely bookmark this one and when I get the time (currently, I'm busy with another deadline), I will try and implement it and provide feedback. Best, HB – HecticBru Aug 25 '16 at 14:26
0

Have a look at this related question. It seems as if you just need to add a sortkey field to your biblio entry. Cheers

  • Thank you for your reply Juan, I will check it out, reply and update the post with any developments. – HecticBru Jul 21 '16 at 15:16
  • Just writing an update here. First of all, the solution requires the package "filecontents", but it clashes (some commands need to be undefined or something) with the already used "natbib", which in turn is required for me to use \citep, etc. (which I must use). Apparently, biblatex can be used instead, but in that case, it clashes with "inputenc" (which I use with parameter utf8x in order to deal with characters such as those with diacritics ("Incompatible package ucs"). There is probably a way forward, but at this point I feel it becomes too hacky and is probably not what the editors wanted. – HecticBru Jul 22 '16 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.