0

I just updated to the "datetime2" package. I live on the east coast of the United States, and used the "\usdate" directive with "datetime". That apparently doesn't work with "datetime2" I installed the "datetime2-english" module as directed.

Obviously, I am not the sharpest knife in the draw; however, I cannot figure out how to get the date printed out in the format ,

Example: Monday January 1, 2016

1

1 Answer 1

4

You need to specify the region. For example:

\documentclass{article}

\usepackage[en-US]{datetime2}

\begin{document}
\today

\end{document}

This produces:

July 23, 2016

If you want the day of week name:

\documentclass{article}

\usepackage[en-US,showdow]{datetime2}

\begin{document}
\today

\end{document}

Saturday July 23, 2016

If this doesn't work for you, add \listfiles to the above and edit your question to show the resulting file list, which should look something like:

 *File List*
 article.cls    2014/09/29 v1.4h Standard LaTeX document class
  size10.clo    2014/09/29 v1.4h Standard LaTeX file (size option)
datetime2.sty    2016/06/05 v1.5.1 (NLCT) date and time formats
tracklang.sty    2015/03/23 v1.2 (NLCT) Track Languages
tracklang.tex
etoolbox.sty    2015/08/02 v2.2a e-TeX tools for LaTeX (JAW)
 xkeyval.sty    2014/12/03 v2.7a package option processing (HA)
 xkeyval.tex    2014/12/03 v2.7a key=value parser (HA)
datetime2-en-US.ldf    2016/03/09 v1.04 (NLCT)
datetime2-english-base.ldf    2016/03/09 v1.04 (NLCT)
datetime2-calc.sty    2016/06/05 v1.5.1 (NLCT)
 pgfkeys.sty    
 pgfkeys.code.tex
pgfcalendar.sty    
  pgfrcs.sty    2015/08/07 v3.0.1a (rcs-revision 1.31)
everyshi.sty    2001/05/15 v3.00 EveryShipout Package (MS)
  pgfrcs.code.tex
pgfcalendar.code.tex    2007/07/23 v3.0.1a (rcs-revision 1.11)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .