8

In uploading a document to arxiv, I'm met with the following error for every single citation:

Package natbib Warning: Citation `citation name' on page 2 undefined on input line x

When I compile the document in TexShop, it seems to run just fine. Similarly, running the following:

latex
bibtex
latex
latex

also works. It's not until I go through the arxiv upload process that I get the natbib warning.

My preamble looks like this:

\documentclass[apj]{emulateapj}
\usepackage{floatrow}
\floatsetup[table]{capposition=top}

And my bibliography section:

\bibliographystyle{apj}
\bibliography{bib_file}

My .bib file is filled with @article entries, most of which were automatically generated, so I'm not worried about typos/syntax errors which may be causing the failure. I've tried just about everything I could think of/find as potential solutions online to no avail.

  • Welcome to TeX.SE. Did you upload the bib file as well? Are there any error message in the .blg file? If so, please tell us about them. – Mico Jul 25 '16 at 3:23
  • @Mico: I did not upload the .bib file per arxiv's instructions. They require only the .bbl file, which I did upload. It doesn't look like there are any errors in the .blg file? It just says "You've used 38 entries...and the built in function call counts are..." below the header info. – uploaderror18 Jul 25 '16 at 4:48
  • 1
    AFAIK Arxiv won't even let you upload a .bib file. You have to either paste the contents of your .bbl file inside the .tex or upload the .bbl – fccoelho Dec 14 '16 at 16:20
  • when did you use natbib i did not see you include the package? – Ka-Wa Yip Jan 10 '17 at 14:04
  • 2
    Before uploading, did you try replacing \bibliography{bib_file} with \input{\jobname.bbl} in the main document, followed by one more LaTeX run? (You should still upload the bbl file, naturally, along with the main tex file(s).) – Mico Apr 11 '17 at 4:47
3

I was having the same problem, and found even uploading the .bbl file was not sufficient. In fact, the .bbl file brought up an error that made the compilation fail, but this shed light on the problem - I had to upload my emulateapj.cls file, as there were some commands defined in that file necessary for the successful compilation of the bibliography.

Thus, I think the solution is:

  • Upload emulateapj.cls

  • You might also need to upload your texfile.bbl

  • Maybe even the texfile.aux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.