2

using LuaLaTeX engine (TeXLive 2015) and Microtype package (2.6a), I am trying to set the default tracking (letterspacing) for all italic fonts (actually, just one font in some size range would suffice), so that I do not have to wrap every \textit in \textls. So far no success.

I am trying to use \DeclareMicrotypeSet and \UseMicrotypeSet, however I cannot (it causes error) use thus defined set in the \SetTracking command, and when I use for this command just the general definition of italic font (encoding = *, shape = it*, size = 8-15) it only works within \textls; it does NOT work by default.

Would anyone know what am I doing wrong or what am I missing? Thanks a lot!

  • BTW, is there anyone here who would agree with the microtype documentation that the package configuration is “straightforward”? – Marcel S. Jul 25 '16 at 20:12
3

Here's a minimal example featuring customised tracking for all italic fonts:

\documentclass{article}
\usepackage{fontspec}
\usepackage[tracking]{microtype}         % 1. Enable tracking
\DeclareMicrotypeSet*[tracking]{italics} % 2. Declare which fonts should 
  { encoding = *, shape = it* }          %    receive tracking adjustment
\SetTracking                             % 3. Specify the tracking amount
  { encoding = *, shape = it* }          %    for the fonts
  {200}
\begin{document}
abc \textit{def} hij
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.