0

Last year I updated my mac to El Capitan, and followed the instructions here to fix the path issues. It was easy!

Today I updated to 10.11.6. The preferences in TeXMaker (my GUI of choice) reverted back to their pre-El Cap settings, and so naturally nothing compiled. I followed the same instructions as before, but this time the fix did nothing.

I tried running latex and pdflatex in terminal, and the commands are not found. On my macbook air that is running 10.11.1, both TexMaker and compiling in terminal work fine.

Any ideas? I don't understand enough about /usr/local/ vs /Library/TeX/ to know how to proceed.

Update: I have now discovered that the folder /Library/TeX/texbin has disappeared after updating to 10.11.6.

Moreover, the TeX Distribution pane in the system preferences won't load and produces the error ``Could not load the TeX Distribution preference pane".

I found this possibly irrelevant remark about the Distribution preference pane in MacTex-2016; or at least I think it's irrelevant because I am sure I have MacTex-2015 installed. So, I tried to check this in TeXLive Utility, but I couldn't get that program working either.

In short I can no longer find my TeX distribution

Strange. I'll try reinstalling MacTex and update again. Thanks folks!

  • Welcome to TeX.SX! I didn't update yet. I'll try tomorrow and report back. – egreg Jul 25 '16 at 23:00
  • I don't use TeXmaker, but I have updated to 10.11.6 and I do not have problems with paths. – Guido Jul 26 '16 at 0:52
0

Reinstalling MacTex (using MacTex-2016) solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.