1

I have the following MWE

\documentclass{standalone} 
\usepackage{psfrag}
\begin{document}
text
\end{document}

I use latex and dvipdf. I have two machines with MacTex-2016. I've just updated with tlmgr on machine A and the MWE produces a full A4 page. On machine B it produces a pdf the size of text (which is what I want). Here are the different lines in the log from machine A

LaTeX2e <2016/03/31> patch level 2
Package: graphics 2016/07/10 v1.0t Standard LaTeX Graphics (DPC,SPQR)
File: graphics.cfg 2016/06/04 v1.11 sample graphics configuration
File: dvips.def 2016/07/10 v3.1a Driver-dependent file (DPC,SPQR)

and from machine B

LaTeX2e <2016/03/31> 
Package: graphics 2016/05/09 v1.0r Standard LaTeX Graphics (DPC,SPQR)
File: graphics.cfg 2016/01/02 v1.10 sample graphics configuration ) 
File: dvips.def 2015/12/30 v3.0k Driver-dependent file (DPC,SPQR)

How do I use tlmgr on machine A to downgrade graphics?

2

Add \usepackage[nosetpagesize]{graphics}

\documentclass{standalone}
\usepackage[nosetpagesize]{graphics}
\usepackage{psfrag}
\begin{document}
text
\end{document}

See also this bug report https://bitbucket.org/martin_scharrer/standalone/issues/25/pagesize-special-clipping

  • That fixes the current problem, thank you, +1. How do I downgrade a package when I know an update is causing trouble, so that I don't have to come here asking for a workaround? – Ramashalanka Jul 26 '16 at 23:25
  • Downgrading standalone wouldn't help. The problem is not due to a change of standalone, but due to changes in the latex core packages and standalone not adjusting to them. You could revert the updates of the graphics files with tlmgr but I wouldn't do it. The work-around is fine. – Ulrike Fischer Jul 27 '16 at 7:59
  • I wasn't talking about downgrading standalone. My original question (above) is "How do I use tlmgr on machine A to downgrade graphics?" The workaround is fine, but I want to know how to downgrade to avoid coming here for help on future bugs. – Ramashalanka Jul 27 '16 at 9:30
  • Sorry I didn't read your question until the end. You find the documentation for restore here: tug.org/texlive/doc/…. But restoring isn't always the best curse of action, also I don't know why you want to avoid to come here -- we are friendly people and quite a lot love to debug and resolve bugs. – Ulrike Fischer Jul 27 '16 at 10:09
  • 1
    You can set the option as global option: \documentclass[nosetpagesize]{standalone} then you will get only a warning in TL15. – Ulrike Fischer Jul 27 '16 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.