1

it seems that I cannot load the biblatex package with initial options:

\usepackage[
  style=alphabetic,
  backend=biber,
  date=long,
  dateabbrev=true
]{biblatex}

this gives me the following errors in the log:

(/usr/share/texmf/tex/latex/biblatex/biblatex.sty
Package biblatex Warning: No "backend" specified, using Biber backend.
(biblatex)                To use BibTeX, load biblatex with 
(biblatex)                the "backend=bibtex" option.
...
(/usr/share/texmf/tex/latex/biblatex/blx-dm.def)
! Package xkeyval Error: no value specified for key `style'.

(/usr/share/texmf/tex/latex/biblatex/blx-compat.def)
! Use of \blx@tempa doesn't match its definition.
\CurrentOption ->s
                  tyle
l.10701

Does anyone know how to fix this issue? Here's a minimal document showing the issue:

\documentclass{article}
\usepackage[printwatermark]{xwatermark}
\usepackage[
  style=alphabetic,
  backend=biber,
  date=long,
  dateabbrev=true
]{biblatex}

\begin{document}
Hello world!
\end{document}
2
  • 1
    Show a small but complete example and the log-file. Jul 26, 2016 at 14:06
  • 1
    Something very odd is going on here, which suggests an issue beyond the snippet posted.
    – Joseph Wright
    Jul 26, 2016 at 15:29

2 Answers 2

5

I found the answer. It is an incompatibility with the xwatermark package:

\usepackage[printwatermark]{xwatermark}

If this package is included before biblatex it somehow breaks the option parsing for biblatex. As of now there seems to be no problem with xwatermark if it is included after biblatex.

Best,

Marcus

1
  • 2
    The issue is due to the fact that xwatermark loads catoptions which does nasty things when changing the default package option processing. It's quite likely to confuse also other packages.
    – egreg
    Aug 11, 2016 at 8:40
1

Looks like

\usepackage[os=win]{menukeys}

before biblatex has the same problem.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .