I want to chronologically sort the citations where the author is printed only once (same author, 2 or more papers from different years). I am trying with the option "citestyle=authoryear-comp." However, it only works for some cases. Here what I have in my .tex file :

\documentclass [12pt]{article}

And here what I have in my .bib file :

title={{Female labour supply and marital status decisions: A life-cycle model}},
author={{van der Klaauw}, Wilbert},
journal={Review of Economic Studies},
volume = {63},
number = {2},
pages = {199--235},
title={{On the Use of Expectations Data in Estimating Structural Dynamic Choice Models}},
author={{van der Klaauw}, Wilbert},
journal={Journal of Labor Economics},
volume = {30},
number = {3},
pages = {521--554},
title={{An empirical investigation of teacher attrition}},
author={{Stinebrickner}, Todd},
journal={Economics of Education Review},
volume = {17},
number = {2},
pages = {127--136},
title={{An analysis of occupational change and departure from the labor force: Evidence of the reasons that teachers leave}},
author={{Stinebrickner}, Todd},
journal={Journal of Human Resources},
volume = {37},
number = {1},
pages = {192--216},

I get :

(van der klaauw 1996, 2012)
(Stinebrickner 2012, 1996)

I don't understand why the outcome is not consistent. I think I should get :

(van der klaauw 1996, 2012)
(Stinebrickner 1996, 2012)

What am I doing wrong ?

  • Are the titles of Stinebrickner's publications really "Title C" and "Title D"? If not, please provide the real titles.
    – Mico
    Jul 27, 2016 at 3:50
  • Here, your document produces always the expected result... Jul 27, 2016 at 5:22
  • I initially simplified the titles to have a MWE but I just noticed the code works well with those simplified titles. I edited the post and put the real titles and the problem shows up. Any insight ? Thanks for your help.
    – celia
    Jul 27, 2016 at 5:45

1 Answer 1


Note that you are loading only the cite-style authoryear-comp with citestyle=authoryear-comp, you do not load the bibliography style. This you can see if you issue \printbibliography, it will have the format you get with bibstyle=numeric.

Because the bibliography style sets the sorting option, you are effectively using the sorting that numeric imposes and that is sorting=nty (name-title-year), but you expect sorting=nyt.

You have two options

  1. Use style=authoryear-comp instead of citestyle=authoryear-comp, that way you also load theappropriate bibliography style
  2. Specify sorting=nyt manually.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.