1

Im using Latex in Linux, was writing and compiling a text in portuguese, everything was working ok, when suddenly all the words with special characters [ ç á à â ã ] intead of those now i have --compo???o-- words with question marks in editor as well as when compiling, would apreciate any help

1

Add \usepackage[utf8]{inputenc} into your preamble if you don't have alreay. UTF-8 encoding should fix the problems with unicode characters.

2
  • Thanks for the support --mwormser--, I used: \usepackage[utf8]{inputenc} to write portuguese but also had to change the format of the source-file in the linux command line with: iconv -f ISO-8859-1 -t UTF-8 file.tex > newfile.tex (newfile is now utf8) and also change the format of the latex editor (texmaker) in the options to: UTF8. After doing all these things I can write and compile again in portuguese. The only bad detail is that I couldnt get back the source-text as it was before I still have those question marks in the source-text. Any suggestion I ll apreciate it – minus Jul 21 '16 at 18:54
  • If you do not have a backup copy of your original text you might be out of luck there and have to replace the broken characters manually, sorry. – Ian Jul 22 '16 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.