2

I'm currently in the process of finishing my bachelor thesis but I'm runnning into some trouble with referencing. For some reason whenever I try to cite anything TexStudio freezes up for a few seconds and then greets my with an error message. I did successfully build and compile documents with a bibliography (exported from Zotero) before and never encountered this problem until now. After reinstalling both the latest TexLive distribution and TexStudio the problem persists. Documents that compile seamlessly before now freeze up and i got these errors:

    No file galvanik_pressler_marzemin.bbl.
    Citation 'shen_growth_2008' on page 9 undefined
    Overfull \hbox (33.48036pt too wide) in paragraph
    Empty bibliography
    There were undefined references.
    Please (re)run Biber on the file:(biblatex) galvanik_pressler_marzemin(biblatex) and rerun LaTeX afterwards.

The messages while running build&view are these

    Process started: biber.exe "galvanik_pressler_marzemin"

    Process started: pdflatex.exe -synctex=1 -interaction=nonstopmode "galvanik_pressler_marzemin".tex

    Process exited normally

So I do know for a fact that Biber was run. I really don't know why it's acting up. Any ideas?

EDIT:

I found a local backup of the original untouched document files that I compiled one of my latest protocols with (including bibliogrpahy). When I tried to build&view again, the document didn't compile and I got these errors.

Use of \sortlist doesn't match its definition. \sortlist{
Extra }, or forgotten \endgroup. \sortlist{none}
Undefined control sequence. \entry{shen_growth_2008}{article}{}
Undefined control sequence. \endentry
Undefined control sequence. \endentry
Extra \endgroup. \begin{document}

Citation 'shen_growth_2008' on page 10 undefined
Overfull \hbox (33.48036pt too wide) in paragraph
Empty bibliography
There were undefined references.
Label(s) may have changed. Rerun to get cross-references right.
Please (re)run Biber on the file:(biblatex) galvanik_pressler_marzemin(biblatex) and rerun LaTeX afterwards.

Also, the .bbl file tells my this

% $ biblatex auxiliary file $
% $ biblatex bbl format version 2.5 $
% Do not modify the above lines!
%
% This is an auxiliary file used by the 'biblatex' package.
% This file may safely be deleted. It will be recreated by
% biber as required.
%
\begingroup
\makeatletter
\@ifundefined{ver@biblatex.sty}
  {\@latex@error
     {Missing 'biblatex' package}
     {The bibliography requires the 'biblatex' package.}
      \aftergroup\endinput}
  {}
\endgroup

What the hell is going on here?

EDIT2:

I deleted the old .bbl file from the original files and tried to run again. It eventually compiled after 30 seconds but the citation was screwed up and no .bbl file was created. The .blg file shows this

[0] Config.pm:324> INFO - This is Biber 2.1
[0] Config.pm:327> INFO - Logfile is 'galvanik_pressler_marzemin.blg'
[51] biber-MSWIN:273> INFO - === %a %b %e, %Y, %H:%M:%S
[52] Biber.pm:333> INFO - Reading 'galvanik_pressler_marzemin.bcf'
[263] Biber.pm:645> INFO - Found 1 citekeys in bib section 0
[304] Biber.pm:2977> INFO - Processing section 0
[343] Biber.pm:3115> INFO - Looking for bibtex format file 'galvanik_prot.bib' for section 0
[356] bibtex.pm:1021> INFO - Decoding LaTeX character macros into UTF-8
[364] bibtex.pm:895> INFO - Found BibTeX data source 'galvanik_prot.bib'
[409] UCollate.pm:66> INFO - Overriding locale 'de-DE' defaults 'variable = shifted' with 'variable = non-ignorable'
[409] UCollate.pm:66> INFO - Overriding locale 'de-DE' defaults 'normalization = NFD' with 'normalization = prenormalized'
[409] Biber.pm:2854> INFO - Sorting list 'none' of type 'entry' with scheme 'none' and locale 'de-DE'
[409] Biber.pm:2858> INFO - No sort tailoring available for locale 'de-DE'
[411] bbl.pm:505> INFO - Writing 'galvanik_pressler_marzemin.bbl' with encoding 'UTF-8'
[423] bbl.pm:596> INFO - Output to galvanik_pressler_marzemin.bbl

EDIT 3:

I tried running a minimal setup (standard bibliography in Texstudio was Biber) using this (bib file with 1 entry on my dropbox) bibliography and this code

\documentclass{scrartcl}

\usepackage[english]{babel}% Recommended
\usepackage{csquotes}% Recommended

\usepackage[style=numeric,backend=biber]{biblatex}

% \bibliography{<mybibfile>}% ONLY selects .bib file; syntax for version <= 1.1b
\addbibresource{biblio_test.bib}% Syntax for version >= 1.2

\begin{document}

A bare citation command: \cite{liu_class_2014}.

A citation command for use in the flow of text: As \textcite{liu_class_2014} said \dots

\printbibliography

\end{document}

After a minute of waiting the error log was

No file test.bbl.
Citation 'liu_class_2014' on page 1 undefined
Citation 'liu_class_2014' on page 1 undefined
Empty bibliography
There were undefined references.
Please (re)run Biber on the file:(biblatex) test(biblatex) and rerun LaTeX afterwards.

Am I screwed?

EDIT 4:

Uploaded a test folder for Ulrike. Thanks for being patient!

EDIT 5:

It seems like it was indeed a compatibility issue with biber and biblatex. I managed to get it working again after a complete reformat and installing a complete MikTex distr and Texstudio. Compiling worked again after deleting all the files except for the .tex files.

EDIT 6:

The problem I mentioned a few comments down with not being able to compile one specific document after doing a full reinstall was due to umlauts in some file names. After editing them it worked again.

26
  • 2
    Welcome, If you just started, i would recommend an update of biblatex and biber with the package manger of your distribution (MikTeX or TeX Live).
    – Johannes_B
    Jul 30 '16 at 18:11
  • 2
    You need to run biber not bibtex. Jul 30 '16 at 20:38
  • 1
    There is no blg in the zip, so you didn't run biber. Jul 31 '16 at 10:59
  • 1
    Does your file name contain special characters? Try avoiding spaces (should not be necessary) and non-ASCII chars as well as other special characters. See also tex.stackexchange.com/q/287923/35864
    – moewe
    Jul 31 '16 at 14:33
  • 1
    Oh god. Again a new system. You had a running texlive 2016, and now you have miktex. I'm giving up. I don't want to waste my time trying to help you to adjust your miktex system only to find out that in the mean time you have erased everything again. Jul 31 '16 at 14:41
2

This may be a biblatex/biber compatibility issue. You seem to have biblatex 3.4 and Biber 2.1. The documentation of biblatex mentions

1.5.5 Compatibility Matrix for biber

biber versions are closely coupled with biblatex versions. You need to have the right combination of the two. biber will throw a fatal error during processing if it encounters information which comes from a biblatex version which is incompatible. Table 1 shows a compatibility matrix for the recent versions.

And according to that table 1, biblatex 3.4 is best paired with biber 2.5.

3
  • Mhh, the OP did an update of TeX live and is (apparently) running TeX live 2016 now. The logs that showed Biber 2.1 are from before the update, I believe. Normally TeX live does not cause version problems, Biber and biblatex are updated simultaneously.
    – moewe
    Jul 31 '16 at 12:00
  • I had a similar issue in 2014 because my MacPorts-based TeXLive installation had biblatex and biber in separate packages without strict version dependency specifications. But it's still a guess.
    – ccorn
    Jul 31 '16 at 12:02
  • I think that's actually what caused it. Today I completely reformatted my computer and installed a complete MikTeX distribution and TexStudio. Compiling worked again once i deleted all the files except for the .tex file. Funny thing is, all my latex documents compile fine except for one which doesn't even contain any bibliogrpahies. I will edit it into the main post, maybe you know something about it. Thanks so far, you're great!
    – smnn
    Jul 31 '16 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.