2

I am writing a paper in IEEEtrans format using Tex, and I use \cite{cmm1,cmm2,cmm3,cmm5}, but when compiling, Latex show them in separate brackets as [1], [2], [3], [4].

How can I fix that?

  • Most likely if you posted a minimum working example (a "MWE") it would attract more answers. meta.tex.stackexchange.com/questions/3343/what-makes-a-good-mwe – A Feldman Jul 31 '16 at 1:52
  • Are you using a citation management package such as cite or natbib? – Mico Jul 31 '16 at 2:01
  • I'm not using anything...just the regular \cite given the IEEE style. – Tina J Jul 31 '16 at 2:06
  • You should try loading the cite package. If you do that, issuing the command \cite{cmm1,cmm2,cmm3,cmm5} should produce [1-4] as its output. – Mico Jul 31 '16 at 2:21
  • 2
    This is by design: the IEEE specify that each reference number should have brackets, rather than the brackets appearing around the entire set of numbers. – Joseph Wright Jul 31 '16 at 6:40
4

In order to generate the refereces with in a pair of square bracket, you can use the package natbib with option numbers. If you need sorting of reference and compressing using ndash, then the option sort&compress can be used.

\usepackage[numbers,sort&compress]{natbib}

A MWE which will work:

\documentclass{IEEEtran}

\usepackage{blindtext}
\usepackage[numbers,sort&compress]{natbib}

\title{Title}

\author{Author}

\begin{document}
\maketitle

\blindtext. This shows how to cite \cite{cite1,cite2,cite3,cite4} in text.

\begin{thebibliography}{4}
\bibitem{cite1} First bib.

\bibitem{cite2} Second bib.

\bibitem{cite3} Third bib.

\bibitem{cite4} Fourth bib.
\end{thebibliography}

\end{document}

Output when sort&compress option is used:

enter image description here

Output when sort&compress option is not used:

enter image description here

There is also cite package when used \usepackage{cite} by replacing \usepackage[numbers,sort&compress]{natbib} in the above MWE will yield the following output:

enter image description here

| improve this answer | |
  • Thanks. But I don't know why when I use \usepackage[numbers,sort&compress]{natbib} it increases the font size of the references, so I get out of page limits! – Tina J Jul 31 '16 at 4:17
  • @TinaJ: For that you need to update either you question with a MWE as show in my answer, which replicate exactly the problem. – Jagath Jul 31 '16 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.