1

I'm using Ubuntu 16.04 LTS and TeX Live 2015/Debian. To make a glossary for my document, my template uses xindy package. I installed it using:

sudo apt install xindy

When I try to compile it, the following error I get.

Cannot locate xindy module for language persian in codepage utf8.

I checked out the /usr/share/xindy/lang directory and found there's no directory for Persian language.

How should I install it? Should I update my TeX distribution?


Update #1

Output of xindy --version

xindy release: unknown
xindy script version: 1.16
xindy kernel version: 3.0
CLISP version 2.49 (2010-07-07) (built on brownie.buildd [127.0.1.1])
    architecture: X86_64
2

As Paul Gaborit mentioned in his comment, xindy of Ubuntu repositories is not the latest version and should be updated to resolve the issue.

The following repo contains the latest version, so you should first add the following line to your /etc/apt/sources.list and then update xindy and xindy-rules.

deb http://ftp.de.debian.org/debian sid main 

Once you're done, you can safely remove this repo from the sources file.

P.S: Mirrors are also available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.