2

I have following problem and I can not find a solution for hours. I tried to use bliblatex, but without [backend=bibtex] it does not work and it says:

! Undefined control sequence. <argument> ...docsvlist \expandafter
{\bbl@loaded }\ifboolexpr { not test {\... l.13 \begin{document} The
control sequence at the end of the top line of your error message was
never \def'ed. If you have misspelled it (e.g., `\hobx'), type `I' and
the correct spelling (e.g., `I\hbox'). Otherwise just continue, and
I'll forget about whatever was undefined.

I used PDFLaTeX -> BibTex -> PDFLaTeX. BibTex said:

Process started

This is BibTeX, Version 0.99d (MiKTeX 2.9) The top-level auxiliary
file: text.aux I found no \citation commands---while reading file
text.aux I found no \bibdata command---while reading file text.aux I
found no \bibstyle command---while reading file text.aux (There were 3
error messages)

Process exited normally

My code:

\documentclass[12pt,a4paper]{scrartcl}
\usepackage[utf8]{inputenc} % UTF8
\usepackage[ngerman]{babel} % Deutsch
\usepackage[T1]{fontenc} % Umlaute für deutsche Sprache erlaubt 
\usepackage{times} % biegt die Schriftarten schöner um


\usepackage{csquotes}               %benötigt für biblatex
%\usepackage[backend=bibtex]{biblatex}
\usepackage{biblatex}
\addbibresource{bibliography.bib}

\begin{document}

Text

\cite{KU}

\cleardoublepage
\addcontentsline{toc}{section}{Literaturverzeichnis} 

\end{document}

My bibliography.bib is:

@book{KU,
 author = {Kant, Immanuel},
 title = {Werkausgabe}, 
 publisher = {Hg. v. Wilhelm Weischedel. Suhrkamp}, 
 address = {Frankfurt am Main},
 year = {1974},
}

I more or less new to LaTeX (and Texmaker), so it is quite possible that I have missed something obvious.

I've read that there could be a problem regarding UTF8 or perhaps the language pack. I even deleted German "ö" and "ä" in the .bib.

Thank you for your help!

closed as off-topic by moewe, user13907, egreg, Jagath, Henri Menke Aug 2 '16 at 13:21

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Further information: When I use the [backend=bibtex] I get this warning: Package biblatex Warning: Data encoding is 'utf8'. (biblatex) Use backend=biber. – SunnyBastard Aug 1 '16 at 19:46
  • 1
    Well, without option backend=bibtex the package biblatex wants informations compiled with program biber. Try pdflatex, biber, pdflatex twice ... Then you have also no problems with the german umlauts, biber can handle utf-8 encoding, bibtex not! – Kurt Aug 1 '16 at 20:13
  • I tried that, too. At the moment I'm thinking that my Texmaker can not handle biber, although I tried this [tex.stackexchange.com/questions/154751/… – SunnyBastard Aug 1 '16 at 20:21
  • 1
    I would not have thought that this really could help and it was my last solution. But, of course, it did help. I thought there would be some kind of automatic updates... Eitherway, thank you a lot! – SunnyBastard Aug 1 '16 at 21:24
  • 4
    I'm voting to close this question as off-topic because it was apparently solved by a MikTeX update (see accepted answer). – moewe Aug 2 '16 at 12:19
1

As you mentioned in one of your comments you are using MIKTeX version 3.1415926-2.3-1.40.12. The current version of MiKTeX is version 3.1415926-2.3-1.40.17, so your MiKTeX is not up to date!

Please update your TeX distribution! Best would be to install the complete MiKTeX, then you should have no problem running biber ...

-1

I think you should try this

\documentclass[12pt,a4paper]{scrartcl}
\usepackage[utf8]{inputenc} % UTF8
\usepackage[ngerman]{babel} % Deutsch
\usepackage[T1]{fontenc} % Umlaute für deutsche Sprache erlaubt 
\usepackage{times} % biegt die Schriftarten schöner um


\usepackage{csquotes}               %benötigt für biblatex
\usepackage{biblatex}

\begin{document}

Text

\cite{KU}

\cleardoublepage
\addcontentsline{toc}{section}{Literaturverzeichnis} 

\bibliographystyle{siam} % change siam to whatever style you like
\bibliography{bibliography} 

\end{document}

And then PDFLaTeX -> BibTex -> PDFLaTeX

Hope this will help you.

  • Not really. The same error (! Undefined control sequence.) and an additional one: \bibliographystyle can only be used in the preamble. – SunnyBastard Aug 1 '16 at 20:08
  • Welcome to the site! I'm afraid this is simply wrong. You are mixing BibTeX without Biblatex with Biblatex with Biber, but it would be wrong even if the backend was set to BibTeX. It is just confused and I suggest you delete the answer. – cfr Aug 1 '16 at 21:30
  • @SunnyBastard Actually, you should not have \bibliographystyle at all since you're using Biblatex. And \bibliography{} needs to go in the preamble. (Or use Biblatex's command, also in the preamble.) – cfr Aug 1 '16 at 21:32
  • Recent versions of biblatex use Buber by default. With those versions you need to use the [backend=bibtex] option. You also can't use many of the advanced features of biblatex. – Herb Schulz Aug 1 '16 at 23:42
  • Thank you, guys. Kurt already had the answer in the comments of my question. I just did not know how to mark it answered without an actual separated answer... – SunnyBastard Aug 2 '16 at 6:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.