2

For the following MWE, I would like to make only the text body double-spaced without affecting chapter titles and references environment.

\begin{filecontents*}{refs.bib}
@article{someguykey2010,
author="SomeGuy",
title="A journal article",
year=2010,
journal="A Journal",
}
@article{someotherguykey2013,
author="SomeOtherGuy",
title="A journal article",
year=2013,
journal="A Journal",
}
\end{filecontents*}

\documentclass{scrreprt}

\usepackage[doublespacing]{setspace}
\usepackage{lipsum} 

\begin{document}

\chapter{Chapter\\Title}

\lipsum[1]

\nocite{*}

\bibliographystyle{plainnat}
\bibliography{refs}

\end{document} 

enter image description here


enter image description here

  • 1
    Remove the option when loading the package and instead add \doublespacing when you really want to start double spacing. Use \singlespacing to stop double. – Johannes_B Aug 2 '16 at 11:27
  • 1
    \addtokomafont{disposition}{\singlespacing} or better \addtokomafont{disposition}{\linespread{1}} – Johannes_B Aug 2 '16 at 11:36
  • 2
    As far as i know, setspace does the job best :-) – Johannes_B Aug 2 '16 at 11:50
  • 1
    @OP It is worth reading the comments provided with the setspace package for a sense of why the solution is likely to be less than ideal. @Johannes_B The singlespace environment would be more appropriate than \singlespacing as the adjustments made are different. I don't know how \linespread compares, but \singlespacing is intended for use in the preamble and adds a \baselineskip. singlespace adds and then subtracts a \baselineskip and is intended for use within the document for portions of text. – cfr Aug 2 '16 at 12:18
  • 1
    I meant the suggested solution using \singlespacing. And, no, I can't provide a good solution. Sorry. As I say, you should read the comments in setspace to understand why not. – cfr Aug 2 '16 at 12:45
2

To not use double-spacing for the headings you could add \setstretch{1} to the setting of font element disposition:

\addtokomafont{disposition}{\setstretch{1}}

As alternative you also could use \linespread{1}, but in this case you should additionally append \selectfont to the font element somewhere after the \linespead command. Otherwise, if a sectioning level would not have a font setting the activation of the new line-spread would be missing.

If you want a sequence of you document without double-spacing use either environment singlespace or command \singlespacing. But if you would use this before a chapter heading, the vertical space above the chapter head would change. So for the bibliography better use it after the heading, e.g., using \AfterBibliographyPreamble.

\begin{filecontents*}{refs.bib}
@article{someguykey2010,
author="SomeGuy",
title="A journal article",
year=2010,
journal="A Journal",
}
@article{someotherguykey2013,
author="SomeOtherGuy",
title="A journal article",
year=2013,
journal="A Journal",
}
\end{filecontents*}

\documentclass{scrreprt}

\usepackage[doublespacing]{setspace}
\usepackage{lipsum}

\addtokomafont{disposition}{\setstretch{1}}

\begin{document}

\chapter{Chapter\\Title}

\lipsum[1]

\nocite{*}

\AfterBibliographyPreamble{\singlespacing}

\bibliographystyle{plainnat}
\bibliography{refs}

\end{document}

results in:

enter image description here

You could also use the opposite: Use doublespacing environment only for those sequences of your document that should be double-spaced:

\begin{filecontents*}{refs.bib}
@article{someguykey2010,
author="SomeGuy",
title="A journal article",
year=2010,
journal="A Journal",
}
@article{someotherguykey2013,
author="SomeOtherGuy",
title="A journal article",
year=2013,
journal="A Journal",
}
\end{filecontents*}

\documentclass{scrreprt}

\usepackage{setspace}
\usepackage{lipsum}

\addtokomafont{disposition}{\setstretch{1}}

\begin{document}

\chapter{Chapter\\Title}

\begin{doublespacing}
\lipsum[1]
\end{doublespacing}

\nocite{*}

\bibliographystyle{plainnat}
\bibliography{refs}

\end{document}

Here the space about chapter heading would be different from the example above:

enter image description here

  • Thanks for your answer. May I know what you mean by adding \selectfont in your statement "as alternative you also could use \linespread{1}, but in this case you should also add \selectfont"? Where should I add it? – Diaa May 1 '17 at 15:40
  • 1
    @DiaaAbidou: See fntguide, section 2.2. – Schweinebacke May 2 '17 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.