1

I'm using arara since my last question about ï & î font encoding, & before, I used the DG' 1.1 answer:

1.1 Call biber with --output_safechars.

To force biber to pass {\"\i} along unchanged, and thus getting the correct output, simply use the option --output_safechars: xelatex document biber --output_safechars document xelatex document xelatex document

When I write, I often excerpt from my bibliographic software a new file .bib. Do you think is it possible to integrate in arara the output_safechars like that:

% arara: xelatex
% arara: biber: {output_safechars: yes}% of course, it doesn't work
% arara: xelatex: {shell: yes}
% arara: xelatex: {shell: yes}

or in the BibTex motor line in my TexShop settings? biber --output_safechars

% arara: xelatex
% arara: biber
% arara: xelatex: {shell: yes}
% arara: xelatex: {shell: yes}% it does not work either

Thanks for your ideas.

  • @egreg I don't think bibtex will work here ;) – cfr Aug 2 '16 at 15:11
  • @cfr I wanted to write biber, of course! :) – egreg Aug 2 '16 at 15:14
3
% arara: biber: { options: "--output_safechars" }

For example, using the code from your earlier question

\begin{filecontents*}{\jobname.bib}
@book{GoncalvesdaCosta:2000tw,
author = {Goncalves Da Costa, H{\'e}lo{\"\i}sa},
title = {{Les mus{\'e}es d'histoire de ville leur contribution au d{\'e}veloppement social contemporain.}},
publisher = {Universit{\'e} du Qu{\'e}bec {\`a} Montr{\'e}al},
year = {2000},
address = {Montr{\'e}al}}
\end{filecontents*}

% !TEX encoding = UTF-8 Unicode
% arara: biber: { options: "--output_safechars" }
\documentclass[12pt]{scrbook}

\usepackage[english,frenchb]{babel}
\usepackage[quiet]{fontspec}

\usepackage[automark]{scrpage2}
\usepackage[babel,french=guillemets*]{csquotes}
\usepackage[backend=biber,style=authortitle-ticomp,doi=false]{biblatex}

\frenchbsetup{FrenchFootnotes=false}
\MakeOuterQuote{"}

% \setmainfont[Mapping=tex-text, Ligatures={Common, Rare}, Numbers={OldStyle}]{Adobe Garamond Pro}

\addtokomafont{disposition}{\normalfont}
\addtokomafont{pageheadfoot}{\normalfont}
\addtokomafont{pagenumber}{\normalfont}
\addtokomafont{footnote}{\normalfont}
\addtokomafont{footnotereference}{\normalfont}

\addbibresource{\jobname.bib}
\AtBeginBibliography{\def\UrlFont{\scriptsize}}

\begin{document}
"Héloïse"\footcite{GoncalvesdaCosta:2000tw}.
\printbibliography
\end{document}

produces the following bibliography

safer bibliography

[I compiled with xelatex -> arara -> xelatex just to isolate the relevant arara line for simplicity.]

| improve this answer | |
  • @Zouib I think it is more Arara grammar, to be honest. You already had the Biber grammar down! – cfr Aug 2 '16 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.