2

I was wondering if there is a way to disable only some of the auto-complete suggestions and auto-corrections in TeXstudio. A couple of concrete examples:

  • When I type \ac{ to add an acronym using the acronym package, my text is automatically corrected to \acute{, which is pretty annoying.

  • First suggestion when typing \begin{eq, is eqnarray. As I only use the equation environment, it would be nice to eliminate this redundant suggestion so as to type faster, aka \begin{eq + Enter.

Do I need to somehow guess in which .cwl files those commands are and disable the whole completion file or is there a cleaner/easier way?

5

The easiest way is to tell TeXstudio to suggest the Most used commands you enter: Menu > Options > Configure > Completion > [Preferred Commands Set] select 'Most Used'.

Other than that, you can create your own .cwl set for TeXStudio to use.

  • Thanks. This did solve my problem with auto-completing \ac to \acute but it does not re-arrange the suggestions based on most used commands (i.e. swap order of eqnarray and equation). Fair enough. Another thing, I have my own command \R for the real numbers and whenever I try to type \R^ it automatically gets corrected to \Re^. Your suggestion does not seem to work there either, any idea why? – Dimitris Aug 3 '16 at 10:24
  • hmm, for a reason after enabling the option you suggest, my own defined commands in the document do not come up at all as suggestions any longer when I type, which is a pain – Dimitris Aug 3 '16 at 12:42
  • @Dimitris Rearanging suggestions by frequency is not possible in TS. To include your own commands in autocompetion list you must create a .cwl file for them, see chapter 4.12 in the teXstudio manual. But for want you want, fast access to very frequent commands or whatever key succesion, better use an external program like Autokey (linux), Autohotkey (win) or whatever is available for Mac. Then you'll have +100 keyboard shortcuts for whatever you use frequently. – alwaysask Aug 3 '16 at 12:46
  • Thanks for your suggestions! For the moment I found a simpler workaround for my issue. – Dimitris Aug 4 '16 at 14:08
4

For the record, in order to at least remove the annoying auto-completion when typing \ac{ to \acute{ (and similar commands) while keeping all other functionalities of TS in place (e.g., suggest all new commands at begin of document while typing) I had to uncheck the box "complete selected text when non-word character is pressed" under TexStudio>Preferences>Completion.

  • Instead it seems to be under Options > Configure TeXstudio > Completion – JJM Driessen Sep 14 '17 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.