0

I've not found a duplicate of this yet but I'm prepared to believe I've overlooked it.

I've been using Lyx a while and some time recently (I can't pinpoint exactly when) it's stopped compiling the Bibliography in my thesis. I haven't changed the .bst file recently, and my .bib library is kept up to date by Mendeley. To be clear the Biblography doesn't appear at all either in the document or in the TOC. If, however, I export from Lyx to PDFLatex and compile it that way (3 or 4 times) it seems to work, and everything appears in-tact.

Things I've tried:

  1. Rescanning the .bib, and deleting/recreating some citations. Nothing changes
  2. Copying the .bib to a new file, using that as the source. No different either.
  3. Duplicating the .bst file, and changing it within the document. Nope
  4. Creating a test file with the same class and bibliography file/style as the original, and making test references. One reference worked, and compiled correctly. Additional references didn't appear, and after adding a fourth the original reference (that had been working!) vanished as well, as did the Bibliography section.

I'm totally stumped by this and really infuriated. Having deadlines doesn't help. Any pointers in the right direction greatly appreciated: I would try and attach a MWE but given how hard it's been to replicate I don't know how much good it'll do!

  • 1
    *.lyx files are text just as LaTex, so you could put that file with the 3 or four cites here, also provide us with a bib source, that would work. This can be a problem in your settings (biber ?) this can be a problem with the path definition, this can be a problem with the bib file itself... – Elad Den Aug 2 '16 at 17:14
  • A MWE might not be helpful, but then again it might. It's worth posting just in case. – Null Aug 2 '16 at 17:14
  • I'm guessing you have a backup from when things worked? It would be strange for things to stop working all of a sudden. Assuming you have a backup, can you look at the differences between the backup and your current version of the files? – scottkosty Aug 2 '16 at 21:30
  • Also, have you upgraded LyX recently? If so, is that when the problem appeared? – scottkosty Aug 2 '16 at 21:31
  • Thanks: I'll throw in a MWE below. I've checked other things like the path to the file (it's fine, and I've moved it and changed it to double check). I've also pulled a backup from May, and it works fine despite being almost identical to the working copy, except for the contents of the included files. I'm trying to work out if this helps me at all! – neophlegm Aug 3 '16 at 17:39
2

Thanks for the tips everyone.

In the end I think I sussed it. Essentially I had attempted to change the appearance of URL dates in my bibliography, by changing the processor to bibtex8 with the option "urldate=long". Once I realised I didn't need it, I changed the processor back to "Default", and it appeared thus:

Greyed-out option

However, when I recovered an earlier version of the main lyx file, and ran diff, it highlighted that even though I'd selected to return to the default processor it was still running through bibtex8 with the option I'd chosen. It seems that even though in the menu it was greyed out (and set to "Default"), the actual content of the file hadn't updated to reflect this. Phew.

I wonder if this is a known thing, and my search terms just weren't quite right? Seems as though someone would've come across it before.

  • If you have a reproducible example and you think there is a bug, please make a bug report at lyx.org/trac – scottkosty Aug 5 '16 at 20:52
0

LyX is definitely finicky with Bibliographies. I've had issues in the past with the following scenarios; maybe one of them fits your description?

  • My LyX file is stored on a cloud system (e.g. Dropbox), and its bibliography is referenced with an absolute instead of a relative file path. When I switch to another computer, it can't find the .bib file.
  • An issue with LyX that is completely unrelated to BibTeX and is usually resolved by closing out of LyX and reopening it.

Can you post more information about your scenario please? e.g.

  • Which LyX version you are using
  • What the source code looks like in the paragraph where you call the Bibliography
  • What error message (if any) you see when compiling
  • If you are using Natbib or something else
  • Any specific custom commands you are invoking in the document's preamble
  • etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.