4

Here is an MWE (compile this with lualatex --shell-escape MWE.tex, you only need to compile once to get the problematic output):

\documentclass{article}

\usepackage{lipsum}
\usepackage[xindy]{imakeidx}
\makeindex
\usepackage{hyperref}

\begin{document}
\lipsum[1]
\index{Lorem ipsum}
\index{Ipsum!Lorem|see{Lorem ipsum}}
\printindex
\end{document}

Here is the rendered index I get on this document1:

picture of rendered index

As you can see, the entry \index{Ipsum!Lorem|see{Lorem ipsum}} is missing. Taking a look at the output of lualatex (this does not appear in the transcript file)2:

Reading raw-index "C:\\Users\\ruben\\Dropbox\\Dokumente\\LaTeX\\hyperref-xindy-mwe\\BjciH3A8V8"...
WARNING: unknown cross-reference-class `hyperindexformat'! (ignored)
Finished reading raw-index.

Taking a look at the MWE.idx file, we can see this instance of hyperindexformat:

\indexentry{Lorem ipsum|hyperpage}{1}
\indexentry{Ipsum!Lorem|hyperindexformat{\see{Lorem ipsum}}}{1}

How can I resolve this issue?


1 The full rendered PDF file can be found and downloaded on this GitHub Gist.
2 Full command output and transcript files can be found in this GitHub Gist.

  • I did not get the output you are showing here using you MWE. I do get Lorem, see Lorem ipsum as part of the output. Have you remembered to typeset it twice? – Runar Aug 6 '16 at 11:09
  • @RunarTrollet: I did typeset it twice (and even thrice), but you should be able to see it the first time (given you use the --shell-escape option). What TeX distribution are you using? I am using TexLive 2016 on Windows x64. – RAnders00 Aug 6 '16 at 11:17
  • @RunarTrollet: Update: I just tried my MWE in a fresh Windows VM with MikTex (opposed to TexLive) and Strawberry Perl and I got the same issue. – RAnders00 Aug 6 '16 at 14:24
  • @RunarTrollet: Another update: Just tried this with TexLive on Ubuntu 16.04.1 (again fresh VM). Same issue. What system are you using? Are you sure you used the exact MWE as provided with the supplied compilation command? – RAnders00 Aug 6 '16 at 17:15
  • 1
    Most of this questions seems to be answered here – ted Jun 19 '18 at 21:59

Browse other questions tagged or ask your own question.