0

I've googled my heart out and I can't seem to find an answer.

The default behaviour in Texmaker (GNU/Linux) is when you hit enter, it will carry over your tabs, such as tabbing like this:

|
|
    |
    |
        |
        |

Is there anyway to turn off this auto-indent when hitting enter. In vim it's: set noautoindent

0

There's no such option in Texmaker.

You can:

  1. use an external program to autoindent the code, see Autoindent in Texmaker which will [hopefully] correct the indentation for you or

  2. switch to TeXstudio, a fork of Texmaker, which has this option in the editor configuration: Menu > Options > Configure TeXstudio > Editor > [Indentation mode] select Ignore Indentation from the drop down.

  • That's disappointing. Odd you can't turn off a very common option. Thank you for the help. – jake Aug 7 '16 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.