2

When typesetting in TeXShop (on Mac), the browser changes from the typesetting editor to the pdf display window when you click the Typeset command. This really slows down my texing.

Is there a way to reconfigure TeXShop so that I stay in the editor after clicking Typeset? It would be great if I didn't have to stop typing every time I refresh the pdf.

  • 1
    under Preferences, Typesetting, After typesetting check Continue typing and it should work, as long as the preview-window is still open, alas, it will not work the first time, but should work after that. – Runar Aug 6 '16 at 19:43
  • @RunarTrollet You should turn this comment into an answer (since it can't get much clearer than what you've written here.) – Alan Munn Aug 6 '16 at 19:53
  • 1
    Note: even if you don't change the preference did you know that Cmd-1 quickly switches between Source and Preview? – Herb Schulz Aug 6 '16 at 19:59
4

Under preferences you will find some settings for controlling this. Select the option Continue Editing under After Typesetting within the tab called Typesetting, as the image below illustrates.

Note that this will only work as long as the preview-window is open, so the first time you launch TexShop and typeset, it will still steal the focus. Keep the preview-window open, and it will not steal the focus again. There are also some options under the Preview-tab, related to position of the preview-window, which could be very helpful.

As noted by Herb Schulz, Cmd-1, will switch quickly between source and preview.

There are of course numerous editors available, see LaTeX Editors/IDEs.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.