0

I have recently upgraded my Ubuntu 14.04 64-bit to Ubuntu 16.04. When I run TeXstudio now from terminal, I am getting the following error message:

$ texstudio texstudio: symbol lookup error: /usr/lib/x86_64-linux-gnu/libpoppler-qt5.so.1: undefined symbol: _ZN13GfxColorSpace17getDisplayProfileEv

It seems some qt5 libraries are messed. Any ideas?

Extra info (for qt4-based texstudio dependencies related to libpoppler*):

$ ldd /usr/bin/texstudio ... libpoppler-qt4.so.4 => /usr/lib/x86_64-linux-gnu/libpoppler-qt4.so.4 (0x00007fb62c61c000) ... libpoppler.so.58 => /usr/local/lib/libpoppler.so.58 (0x00007fb6292a8000) ...

  • Have you tried reinstalling texstudio? – daleif Aug 8 '16 at 5:17
  • 1
    Try this. If no luck, in case you installed TeXstudio from Ubuntu repositories, uninstall it, run sudo apt autoremove and download & install from texstudio.sourceforge.net/#download (I prefer the Qt4 version). – alwaysask Aug 8 '16 at 5:31
  • @alwaysask Thank you for your response. Unfortunately, your first idea is not so clear to me. Which files do I have to remove? The second idea gives me new error message: $ sudo dpkg -i texstudio-qt4_2.11.0_amd64.deb [sudo] password for vl: (Reading database ... 806694 files and directories currently installed.) Preparing to unpack texstudio-qt4_2.11.0_amd64.deb ... Unpacking texstudio-qt4 (2.11.0) ... dpkg: error processing archive texstudio-qt4_2.11.0_amd64.deb (--install): trying to overwrite '/usr/share/texstudio/template_Moderncv.json' – Vladimir S. Aug 8 '16 at 5:56
  • First thing I suggested is to look for symlinks or lib files where that link says on your system. As for your install error, did you uninstall the old TeXstudio version prior to installing the new version? – alwaysask Aug 8 '16 at 6:06
  • 1
    There are some issues with the Qt libraries on your system, probably from something your tried to install, didn't work and improperly fixed it. Unfortunately this is offtopic on TeX.SX. Try finding a solution from these search results – alwaysask Aug 8 '16 at 6:34
0

Finally, the suggestions from @alwaysask, the report and discussion helped me to figure out what I have to do.

I moved all poppler related files from /usr/local/lib to temporary user directory ( /home/vl/software/lib ) like

sudo mv /usr/local/lib/libpoppler* /home/vl/software/lib

and after that the texstudio (qt4-based package: texstudio-qt4_2.11.0_amd64.deb ) is successfully running again!!!

  • 1
    This is what my first suggestion link said in the reply there - improperly/wrongly placed libs (or symlinks to them) in the /usr/local/lib folder :) Glad you finally worked it out. – alwaysask Aug 8 '16 at 9:59
  • @alwaysask I agree, you gave me the right direction. Many thanks! The case in the question is similar but the answer is not so evident because I did not know which files I have to re/move. – Vladimir S. Aug 8 '16 at 10:05
  • Well, the keywords there are "package manager doesn't put any libraries there". In the /usr/local/lib folder there should be no files (let alone files with lib in their name), only folders. For example, on my system: ls /usr/local/lib shows 2 python folders and the x86_64-linux-gnu folder. So make sure there are no other files in there (move them elsewhere if they are, same as you did with the libpoppler ones), otherwise some other errors mght pop up when least expected and in a hurry. – alwaysask Aug 8 '16 at 10:14
  • @alwaysask Your brief explanation sounds very clear now and deserves putting it into wiki page or you may want to convert it to an answer and post it here. Anyway, I am ready to upvote it! PS. My computer has passed several upgrades (12.04 -> 14.04 -> 16.04) and many installations so that I am not so surprised seeing such 'unwanted' files. – Vladimir S. Aug 8 '16 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.