1

I am using MacTex 2016 on a Mac (El Captain 10.11.2). My text editor is TexStudio 2.11.0 and all my packages have been updated (TeX live Utility 1.24).

I edited a map in Inkscape and saved it as a pdf file. The background map was a PNG picture. When I open the pdf on my computer, it looks fine.

enter image description here

However, when I insert this pdf in my latex file using the following code (I compile using XeLateX), the map shows only partially up.

enter image description here

\documentclass{book}
\usepackage[french]{babel}
\usepackage{fontspec}
\usepackage{graphicx}
\usepackage{caption}
\usepackage{float}

\begin{document}

\begin{figure}[H]
\captionsetup{labelformat=simple, labelsep=period}
\caption{Les principales isoglosses vocaliques observées aux îles Féroé}\label{fercarte2}
\includegraphics[width=\textwidth]{fercarte2}
\end{figure}

\end{document}

I have no idea why. Could the problem be in the file itself or did I miss something in my code?

Here is the pdf file of the map : https://drive.google.com/open?id=0B_S6SJw6ZBivSUJ3TFlIdFprVlk

Thanks in advance for your advice!

1
  • 1
    On RedHat Linux with TeXLive 2016, the image shows up properly. Nice image, by the way. – hbaderts Aug 9 '16 at 9:08
1

So I managed to make the picture show up properly... I re-opened my picture in Inkscape and saved it as a .ps. I replaced the .pdf file with the .ps one in the folder where Latex can find the files to insert. Still, I don't get why the pdf image didn't work. I had no error nor warning message, just a partial picture. Besides, in another .tex file, I have inserted a pdf image (without editing it) and it appeared fine after the compilation. I leave this post in case anyone is facing the same "strangeness".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.