2

I'm using Zotero Better BibTeX to automatically import the bibliography I need, but it uses BibLaTeX and BibTeX, and I am required to use Chicago style. I think

\usepackage[backend=biber,style=chicago-authordate,natbib=true]{biblatex}

would be perfect. However, I'm having trouble to convert to biber.

When I use biber as a backend, following lockstep's advice, i.e. LaTeX Biber LaTeX, I get no errors, but the in-text citations are the automated keys Zotero generates: author_firsttitleword_date. If I rerun LaTeX, I get a lot of "undefined control sequence \entry" and "\endentry", and the logfile is the following monster:

! Use of \sortlist doesn't match its definition.
l.21   \sortlist{
             nty}{nty}
If you say, e.g., `\def\a1{...}', then you must always
put `1' after `\a', since control sequence names are
made up of letters only. The macro here has not been
followed by the required stuff, so I'm ignoring it.

! Extra }, or forgotten \endgroup.
l.21   \sortlist{nty}
                 {nty}
I've deleted a group-closing symbol because it seems to be
spurious, as in `$x}$'. But perhaps the } is legitimate and
you forgot something else, as in `\hbox{$x}'. In such cases
the way to recover is to insert both the forgotten and the
deleted material, e.g., by typing `I$}'.

! Undefined control sequence.
\entry ...ata@\the \c@refsection @\blx@slist@name 
                                             @\abx@field@entrykey 
}\csu...
l.22     \entry{__2004}{article}{}

The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

! Undefined control sequence.
<argument> ...equal \expandafter {\blx@slist@type
                                              }{entry} {\listcsxadd {blx...
l.33     \endentry

The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

(This is the first time I ask a question, bear with me)

Would programming a new command make sense here? Stick with BibTeX but use a command making the "(Demmer, 2003: 165)" format into "(Demmer 2003: 165)". Is that possible?

  • 2
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – DG' Aug 9 '16 at 19:14
  • You need to make sure that you (or your editor) actually run Biber on your file and not still BibTeX. (Check out Biblatex with Biber: Configuring my editor to avoid undefined citations for help with your editor.) If you change the backend it is a good idea to delete the temporary files (.aux, .bcf, .bbl) before recompiling from scratch. You need also to make sure that your versions of Biber and biblatex match (you can find a version matrix in the biblatexdocs) – moewe Aug 10 '16 at 7:29
  • For further generic hints see Troubleshooting for biber. You might also want to check out the contents of the .blg file (if you use Windows you might need to enable the option to show file extensions to find that file). – moewe Aug 10 '16 at 7:31