0

I am using the following package: \usepackage[utf8]{inputenc}

After adding another paragraph of text into sharelatex as usual, the following error occured:

'Package inputenc Error: Unicode char -> (U+2192)

Can someone please tell me what this means and what I have to do to get rid of this error. I can still compile the text and the text looks fine.

6
  • 1
    Use $\to$ instead of →. Aug 9, 2016 at 19:55
  • That is the error which says -> I didn't put it?
    – Lana
    Aug 9, 2016 at 20:42
  • wat? I don't get it. Aug 9, 2016 at 20:51
  • @HenriMenke Lana thinks you suggested her to replace the -> in the error message she posted above. I don't get what the question mark is for though ...
    – alwaysask
    Aug 9, 2016 at 21:24
  • I think the mixup here as to whether the $\to$ or -> can be easily solved by posting a MWE. It is hard to tell what is causing the error when we have just one line of code...
    – Elad Den
    Aug 10, 2016 at 6:45

1 Answer 1

1

U+2192 is a rightarrow so you must have an explicit → in your document.

Note that the default utf8 inputenc settings cover most latin alphabet text characters, but not extended unicode ranges for math or other scripts. these can be added on demand as for example

\DeclareUnicodeCharacter{2192}{\rightarrow}% math mode arrow

However you should not get the error that you show on a current latex as U+2192 is predefined as a text mode right arrow, inputenc has the definition

\DeclareUnicodeCharacter{2192}{\textrightarrow}

Please show a full small document and the full error message.

1
  • I already fixed it, but thanx though! :)
    – Lana
    Aug 10, 2016 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.