1

I am using "jaxodraw-2.1-0.jar" and the "axodraw4j.sty" file is inside the directory where I am drawing and keeping my diagrams. Whenever I try to export the diagram it shows "Cannot execute command! Please try 'export LaTeX' and run latex manually." so I did. I ran the generated latex code using my "texmaker". First I used "pdflatex" and it generated a blank figure with just the latex labels but no arrows or anything ! Then I read somewhere that I must do "Latex->Dvips->Ps2Pdf-" etc so I configured my "quickbuild" tab in texmaker that way and executed which showed the following error


Process started

warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/local/texlive/2015/bin/x86_64-linux:/usr/local/texlive/2015/bin/x86_64-linux/share/texmf-local/web2c:/usr/local/texlive/2015/bin/x86_64-linux/share/texmf-dist/web2c:/usr/local/texlive/2015/bin/x86_64-linux/share/texmf/web2c:/usr/local/texlive/2015/bin/x86_64-linux/texmf-local/web2c:/usr/local/texlive/2015/bin/x86_64-linux/texmf-dist/web2c:/usr/local/texlive/2015/bin/x86_64-linux/texmf/web2c:/usr/local/texlive/2015/bin:/usr/local/texlive/2015/bin/share/texmf-local/web2c:/usr/local/texlive/2015/bin/share/texmf-dist/web2c:/usr/local/texlive/2015/bin/share/texmf/web2c:/usr/local/texlive/2015/bin/texmf-local/web2c:/usr/local/texlive/2015/bin/texmf-dist/web2c:/usr/local/texlive/2015/bin/texmf/web2c:/usr/local/texlive/texmf-local/web2c:/usr/local/texlive/2015:/usr/local/texlive/2015/share/texmf-local/web2c:/usr/local/texlive/2015/share/texmf-dist/web2c:/usr/local/texlive/2015/share/texmf/web2c:/usr/local/texlive/2015/texmf-local/web2c:/usr/local/texlive/2015/texmf-dist/web2c:/usr/local/texlive/2015/texmf/web2c. This is dvips(k) 5.995 Copyright 2015 Radical Eye Software (www.radicaleye.com) dvips: ! Couldn't find header file: tex.pro

Process exited with error(s)


So I came back to jaxodraw and opened "preferences", I saw that the two fields: latex path and dvips path are empty. I wrote latex in the latex path and dvips in the dvips path because I don't know what else to do.. I have no idea what is the exact path for them ! Then I tried to export again using the default "LaTeX->EPS" it showed another error: "Error:_Executionof_dvips_failed!" I think if I could specify the right paths for latex and dvips it will export correctly and will directly generate the EPS file.. because I remember I used jaxodraw in another computer with ubuntu many months ago and that was generating the EPS directly and seamlessly ! But I don't know what are the paths.

Additional info:

I am using Ubuntu 16.04.1 LTS and it's Lubuntu. I have installed Texlive Vanilla following the instructions given here: How to install "vanilla" TeXLive on Debian or Ubuntu?

Any help will be highly appreciated because I am really stuck.

PS: If I choose just "EPS" instead of "LaTeX->EPS" it produces the diagrams without any latex labels, so again useless.

1

The error message indicates that your TeXLive installation is corrupted or incomplete. It shows that the programs latex and dvips were indeed run, but that the files texmf.cnf and tex.pro are missing, even though they are essential to the functioning of these programs. They should have been created by a standard install of TeXLive 2015 in the following locations:

/usr/local/texlive/2015/texmf.cnf
/usr/local/texlive/2015/texmf/web2c/texmf.cnf
/usr/local/texlive/2015/texmf/dvips/base/tex.pro

I would recommend reinstalling TeXLive (of which the current version when I wrote this answer is TeXLive 2016). I'd recommend you to make this a full installation, and take the default options.

After that latex and dvips should work.

Once you have a correctly functioning TeXLive installation, jaxodraw's export to eps should work with jaxodraw's default settings for the paths to latex and dvips, which are just the strings 'latex' and 'dvips'.

  • Thanks a lot, it did work after installing the new version (2016 and up[stream) of the texlive, although there seems to be another problem not related to jaxodraw. This has to do with the "PATH" problem of latex itself. I can't update anything using tlmgr and even after deleting Texlive 2015, the pdflatex seems to be using the old version mysteriously. Here's a link to the question that I have created: tex.stackexchange.com/questions/325364/… – quanta Aug 18 '16 at 3:44
  • Update: after trying everything to solve the texlive version conflicts, in the end I completely purged all the versions of Texlive and anything related then followed this excellent answer step by step, everything seems now working perfectly. – quanta Aug 20 '16 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.