1

I am getting an error when I attempt to compile my document, this has appeared since I added a few more references to Mendeley and auto generated the bib files. I get the above error pointing to the entries for the recently added reference in the .bbl file.

I tried removing the offending reference, however there are three causing problems it seems, and I do need these references.

This problem appears to be similar

However I have tried the suggested solution and hasn't worked for me. Everything is uptodate.

I include biblatex with these settings,

\usepackage[
    natbib=true,
    hyperref=true,
    backend=bibtex,
    backref=true,
    url=false,
    arxiv=false,
    isbn=false,
    doi=false,
    maxcitenames=3,
    maxbibnames=100,
    style=numeric-comp,
    sorting=none
]{biblatex}

A MWE follows:

    \documentclass[11pt,twoside,a4paper]{article} % for the MSc in Informatics

\usepackage{microtype}
\usepackage{textcomp,gensymb}
\usepackage{array}
\usepackage{titlesec} 

\usepackage[english]{babel}
\usepackage{lastpage}
\usepackage{xifthen}
\usepackage{lipsum}
\usepackage{hyperref}
\usepackage{listings}
\usepackage{amsmath}
\usepackage{tikz}
\usepackage{booktabs,siunitx}
\usepackage[nottoc,numbib]{tocbibind}

\makeatletter
\def\blx@maxline{77}
\makeatother

\usepackage[natbib=true,hyperref=true,backend=bibtex,backref=true,url=false,arxiv=false,isbn=false,doi=false,maxcitenames=3,maxbibnames=100,style=numeric-comp,sorting=none]{biblatex}

\addbibresource{Thesis-Weblinks.bib}

% redefine headings
\titleformat{\chapter}[hang]{\LARGE\bfseries\sffamily}{\thechapter\hspace{1em}}{0pt}{}

%% Information about the title, etc.
\title{MSc thesis \\ Your title here}
\author{A name \\ }


\begin{document}

an example \citet{Media2016}

\maketitle


\printbibliography

\end{document}

And the bib file:

Automatically generated by Mendeley Desktop 1.16.1
Any changes to this file will be lost if it is regenerated by Mendeley.

BibTeX export options can be customized via Options -> BibTeX in Mendeley Desktop

@misc{Media2016,
author = {Media, Common Sense},
keywords = {CSMMinecraft},
mendeley-tags = {CSMMinecraft},
title = {{Common Sense Media}},
url = {https://www.commonsensemedia.org/game-reviews/minecraft/user-reviews/child https://www.commonsensemedia.org/game-reviews/wii-sports https://www.commonsensemedia.org/},
urldate = {2016-08-09},
year = {2016}
}
14
  • The answer there should actually work. Can you post a full MWE of how it didn't work for you? Using Biber instead of BibTeX will of course also solve the issue.
    – moewe
    Aug 11 '16 at 10:07
  • Did you recompile (pdflatex + bibtex +pdflatex) after adding the fix? Aug 11 '16 at 10:24
  • I copied over all the docs used into a new folder and compiled afresh there, the issue is isolated within this small example
    – Culzean
    Aug 11 '16 at 10:27
  • 2
    I have got biber working now and this seems to fix my problems. It does throw some warnings about characters than cannot be encoded in ascii and then recodes. I'll switch to biber and that fixes my problems. I don't know if there is a more general solution or answer that can be posted? Thanks everyone for chipping in and helping :)
    – Culzean
    Aug 11 '16 at 11:45
  • 1
    Well, Biber is the right choice. But if you had wanted to use BibTeX you should hgave simply followed Ulrike's advice and added the fix after loading biblatex (I just checked, it worked after I moved the \makeatletter bit). Note also that the url field should only ever contain one URL at a time, multiple URLs are bound to cause confusion, if not outright trouble.
    – moewe
    Aug 11 '16 at 12:02