9

Today I installed Miktex 2.9 and now I am having problems trying to compile a file which uses dsfont package. When running, I am asked to install dstroke package. I press yes which results in getting '! LaTeX Error: File `dsfont.sty' not found.'

Here are 2 lines from the logs which might be of interest (I tried other mirrors too, not only Texas):

2016-08-13 19:21:02,171+0300 INFO pdflatex - mpm: downloading ftp://mirror.utexas.edu/pub/ctan/systems/win32/miktex/tm/packages/next/dstroke.cab... 2016-08-13 19:21:05,977+0300 FATAL pdflatex - Remote file not found

How can I solve this problem?

EDIT As suggested in teh comment by Ulrike Fisher, tried to use MikTex package manager to synchronize and download packages. Got another error 'unknown archive file size'. Ended up just copying the .sty file to the directory of the tex file.

  • 1
    Synchronize your local package database, see tex.stackexchange.com/a/108490/2388. (You seem to use the next repositories, which I don't, so I can't test if there is a problem there. In the normal repositories the font is in the doublestroke package. – Ulrike Fischer Aug 13 '16 at 16:30
  • @UlrikeFischer Thanks I tried to follow the instructions in your link but now I am getting another error in Miktex package manager: Permission denied: path="C:\Users\Sinus\AppData\Local\MiKTeX\2.9\miktex/data/le\df2c24cb21984fa85003c1ecc818ff83.fndb" – Sinusx Aug 13 '16 at 16:48
  • Make sure that no miktex related application is open. – Ulrike Fischer Aug 13 '16 at 16:53
8

It's a little bit messy!

First, go to Miktex package manager (admin) and Miketex package manager and under the tab Repository click on Synchronize.

Then, go back to Miktex package manager (admin) and search for doublestroke package.

After installing this package, it is fine to use \usepackage{dsfont} (not \usepackage{doublestroke}).

  • it's \usepackage{dsfont} without the "s". I am not allowed to change just one character in your answer – CodingYourLife Feb 25 '17 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.