2

I was unable to update Texlive 2015 using tlmgr so I installed the latest version, that is 2016 following the instructions. After the installation of 2016 I removed the old (2015) version and set the path to

PATH=/usr/local/texlive/2016/bin/x86_64-linux:$PATH

I also compiled a lot of tex files without any errors and also the installation log file (of 2016) showed no signs of errors. Then I tried to check if the update command (tlmgr update --self ) works, it didn't ! The error message was:

All good.
Uncompressing TeX Live Manager Updater............................................................................................................................................................................
./runme.sh: Cannot find TeX Live root using kpsewhich --var-value=SELFAUTOPARENT.
./runme.sh: Please set your PATH as needed, otherwise it's hopeless.

Can anyone please help me understand what needs to be done, for example: I don't understand why is it still asking for a "PATH" given the fact that I have already set it up typing the following line in the terminal:

PATH=/usr/local/texlive/2016/bin/x86_64-linux:$PATH

Out of curiosity I then repeated the update command by specifying the whole path, that is:

/usr/local/texlive/2016/bin/x86_64-linux/tlmgr update --self  

And it worked, because the output was:

tlmgr: package repository http://ctan.mirror.garr.it/mirrors/CTAN/systems/texlive/tlnet (verified)
tlmgr: saving backups to /usr/local/texlive/2016/tlpkg/backups
tlmgr: no self-updates for tlmgr available.

So I tried to update the packages instead by using:

/usr/local/texlive/2016/bin/x86_64-linux/tlmgr update --all

which also worked and returned:

tlmgr: package repository http://ctan.mirror.garr.it/mirrors/CTAN/systems/texlive/tlnet 
(verified)
tlmgr: saving backups to /usr/local/texlive/2016/tlpkg/backups
[ 1/20, ??:??/??:??] update: europasscv [378k] (41201 -> 41866) ... done
[ 2/20, 00:05/04:04] update: glossaries-extra [3355k] (41486 -> 41856) ... done
[ 3/20, 00:09/00:44] update: latexpand [8k] (37592 -> 41873) ... done
[ 4/20, 00:10/00:49] update: markdown [333k] (41376 -> 41855) ... done
[ 5/20, 00:12/00:54] update: mweights [3k] (31268 -> 41867) ... done
[ 6/20, 00:16/01:12] update: newpx [1707k] (39698 -> 41863) ... done
[ 7/20, 00:22/01:10] update: newtx [4028k] (40165 -> 41864) ... done
[ 8/20, 00:27/00:50] update: parnotes [129k] (41775 -> 41868) ... done
[ 9/20, 00:29/00:53] update: texlive-docindex [220k] (41843 -> 41862) ... done
[10/20, 00:31/00:56] update: udesoftec [618k] (40613 -> 41872) ... done
[11/20, 00:32/00:54] auto-install: cormorantgaramond (41865) [5284k] ... done
[12/20, 00:37/00:42] auto-install: phffullpagefigure (41857) [250k] ... done
[13/20, 00:38/00:42] auto-install: phfnote (41858) [667k] ... done
[14/20, 00:39/00:42] auto-install: phfparen (41859) [311k] ... done
[15/20, 00:40/00:42] auto-install: phfqit (41860) [343k] ... done
[16/20, 00:40/00:41] auto-install: phfquotetext (41869) [201k] ... done
[17/20, 00:41/00:42] auto-install: phfsvnwatermark (41870) [208k] ... done
[18/20, 00:42/00:42] auto-install: phfthm (41871) [397k] ... done
[19/20, 00:43/00:43] update: collection-fontsextra [2k] (41736 -> 41865) ... done
[20/20, 00:44/00:44] update: collection-latexextra [6k] (41853 -> 41871) ... done
tlmgr: package log updated: /usr/local/texlive/2016/texmf-var/web2c/tlmgr.log
running mktexlsr ...
done running mktexlsr.
running mtxrun --generate ...
done running mtxrun --generate.
running updmap-sys ...
done running updmap-sys.

I would like to know how can I really solve this "PATH" problem. I can specify the whole path each time but I really don't want to.

Some other information that I would like to provide are:

which tex

returns /usr/bin/tex

Similarly which latex and which pdflatex etc return /usr/bin/latex and /usr/bin/pdflatex

So clearly the path specification didn't work!


Forgot to add the log file of a tex compilation which I think is important

The log file was too big so I decided to save it as a "google do" and provide the link here.
I am pasting the first line though:

This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015/Debian) (preloaded format=pdflatex 2016.5.23)

Does it say I am still using texlive 2015? I don't know how is that even possible because I have erased the whole directory /usr/local/texlive/2015 there's only one directory/file inside /usr/local/texlive and that is 2016.

closed as off-topic by TeXnician, ebosi, Zarko, Stefan Pinnow, Torbjørn T. May 25 '17 at 20:32

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did you just write PATH=/usr/local/texlive/2016/bin/x86_64-linux:$PATH in a terminal? I usually put this information in my .profile (which you must source if you're still in the same terminal 'session'). – jon Aug 18 '16 at 4:08
  • Your commands use the TeXLive distribution installed by your OS (Debian, Ubuntu or any variant). You may change your .profile to add the correct PATH (just for you). You may change the PATH in /etc/environment to add the correct PATH (for all users). – Paul Gaborit Aug 18 '16 at 7:06
  • You may read section 3.4 (3.4.1 and 3.4.2) from the TeX Live Guide... – Paul Gaborit Aug 18 '16 at 7:10
  • You may want to read profs.sci.univr.it/~gregorio/texlive-YEAR-ubuntu.pdf (change the year into 2016, of course). You can skip much of the procedure, go where /opt/texbin is defined and where the PATH environment variable is dealt with. – egreg Aug 18 '16 at 8:20
  • 4
    I'm voting to close this question as off-topic because it was solved by reinstallation. – TeXnician May 25 '17 at 18:57