3

I am on a university computer (Windows 8.1, 64-bit) where MikTeX 2.9 is installed in multiuser mode via Software Center, and I am having trouble getting biber to run (The MikTeX-installation seems to be working fine except for this.). Trying to run biber on the command line outputs nothing, produces no bbl- or blg-file and only returns to the prompt. However, it does produce the folder C:\Users\username\AppData\Local\Temp\par-somenumbers with some files in it.

Others have had similar problems with biber on Windows (here and here) and Linux, and the problem seems to be related to permissions required by biber, in particular in relation to the Temp-folder mentioned above, but I fail to understand exactly what those permissions are since my user already has write-permissions to the Temp-folder.

As was suggested in the first link above, biber runs fine if my IT-manager opens a command line as an administrator. However, this is not an option for me or others on a managed computer. So how can biber be given the necessary permissions so that a user without administrator rights can run it, both from the command line or from within an IDE such as TeXnicCenter?

6
  • 2
    Does the files in the temp/par-folder complete? E.g. are there the .dll's ? If not something perhaps blocks biber to unpack everything. You could then try to set the PAR_GLOBAL_TEMP variable to some other folder. see github.com/plk/biber/issues/70 Commented Aug 18, 2016 at 14:07
  • 1
    There were four .dll's and biber.exe in the par-folder, but setting the PAR_GLOBAL_TEMP variable to a new folder under the Documents folder seems to have solved this frustrating problem. Thank you! In searching for how to set PAR_GLOBAL_TEMP, I came across your answer here to essentially the same problem, except that there was an error message in that case.
    – vgnils
    Commented Aug 18, 2016 at 14:48
  • @UlrikeFischer Seems everything is not well quite yet... biberstill won't run from within TeXnicCenter? My settings are taken from here. And if I exit the command prompt, the PAR_GLOBAL_TEMP variable is discarded? How can I set it permanently?
    – vgnils
    Commented Aug 18, 2016 at 15:06
  • 1
    Search in windows for "environment variables", it should point you to the place where the user can store them. Commented Aug 18, 2016 at 15:16
  • @UlrikeFischer Great, now everything works. Thanks! I don't know if my question should be marked as a duplicate or if it should be answered...?
    – vgnils
    Commented Aug 18, 2016 at 16:55

1 Answer 1

3

At the first run biber needs to unpack a lot of files in a temporary folder. Sometimes some security setting can block the unpacking -- completely or only some files.

You then can try to set the PAR_GLOBAL_TEMP environment variable to point to some other folder where you have free write access.

See https://github.com/plk/biber/issues/70

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .