I'm trying to define a box in a page (the title page indeed) that should appear as 'transparent' over the page background (that's a .jpg picture).

The code I'm using is the following:

\author{The author}
\title{The title}
\editor{The editor}

Inside 'defines.sty' I defined the structure and commands:



            \eachpageornament \thepage
            \ifnum\value {page}=1 
                \eachpageornament \thepage
    position=current page.north east,



    \begin{tikzpicture}[remember picture, overlay, color=LimeGreen]
    \node[anchor=north west](CNW) at (current page.north west){
    \node[anchor=north east](CNE) at (current page.north east){
    \node[anchor=south west](CSW) at (current page.south west){
    \node[anchor=south east](CSE) at (current page.south east){

\newcommand{\plogo}{\includegraphics[width = 30mm]{logo.png}}



    \begin{tikzpicture}[remember picture, overlay]
    \node [rectangle, rounded corners, fill=LimeGreen, opacity=0.75, anchor=south west, minimum width=6cm, minimum height=8cm] (box) at (-0.5,-10) (box){};
    \node[anchor=west, xshift=-2.0cm, yshift=-1cm, text width=4cm] at (box.north){\large \textit{\theeditor}}; 
    \node[anchor=west, xshift=-2.0cm, yshift=-3.5cm, text width=4cm] at (box.north){\huge \thetitle};
    \node[anchor=west, xshift=-2.0cm, yshift=-6cm, text width=4cm] at (box.north){\large \theauthor};




This node instance should define a green rounded box with 75% opacity:

\node [rectangle, rounded corners, fill=LimeGreen, opacity=0.75, anchor=south west, minimum width=6cm, minimum height=8cm] (box) at (-0.5,-10) (box){};

But as long as I can see the box is filled with solid green...

The original template were I took the suggestion can be found at the following link: book sample

Of course it's working... but as far as I can see there are no differences with mine that would change the behavour of the box.


The package transparent, automatically loaded by the package svg conflicts with TikZ opacity key.

You may:

  1. Unload the svg package so that TikZ opacity will work as expected
  2. Unload the transparent package, which is the real source of the conflict by issuing \expandafter\def\csname ver@transparent.sty\endcsname{}¹ before loading svg (this may cause the svg package to misbehave)
  3. use the \transparent macro instead of Tikz opacity key, like this:

     {\transparent{0.5}\node [rectangle, rounded corners, fill=LimeGreen, anchor=south west, minimum width=6cm, minimum height=8cm] (box) at (-0.5,-10) (box){};}

The grouping outside \transparent prevents the macro to be applied to the whole tikzpicture

¹see also svg package interfers with opacity

  • I tried that .. but it's not working... no errors but it just renders the same way it did previously. I can try using a bitmap instead the .svg file but it's not a quality solution. – weirdgyn Aug 18 '16 at 20:50
  • @weirdgyn it does not work with the \transparent macro (solution 3)? It works here, I can see the correct opacity. – Nico Boni Aug 18 '16 at 20:54
  • @weirdgyn I just discovered that you may need two consecutive compilation so that \transparent{0.5} works. Try compiling twice. – Nico Boni Aug 18 '16 at 20:59
  • yeah.... quite strange anyway.... :-) – weirdgyn Aug 18 '16 at 21:05
  • 1
    svg now provides an option notransparent (or usetransparent=false) to disable the loading of the transparent package. – schtandard Apr 18 '18 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.