0

My system is Windows 10. I have recently started to work with LaTeX. For writing I use TeXmaker. I am trying to get the citation and bibliography functions working. I have generated a .bib-file with the BibTex-Funktion of Mendeley. I saved the .bib-file in the same directory as my .tex-document. My test document for citation and bibliography looks like this:

\documentclass{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[babel, german=guillemets]{csquotes}
\usepackage[style=authoryear, backend=biber]{biblatex}
\bibliography{library02.bib}
\begin{document}
\cite{Angelica2008}
\printbibliography
\end{document}

After saving the .tex-document I ran latex on the file: latex C:...\beispiel02.tex - that worked.

In a next step I ran biber: biber beispiel02

I tried this in quite some varying .tex-documents, directory structures and commands etc., but I always get the Error: cannot find library02.bib

I have already looked for hidden extension files (a phenomenon previously described in this forum) but I found none.

My biber version is 2.5. TeX Live Manager didn't give me any possible further updates, neither for biblatex.

I opened my .bib-file with Jabref, which worked, and saved it again with this program. I made sure that the settings were on saving files as utf-8.

I also tried to put in the full directory path of the library, or saving the library.bib in another folder (also in the texmf folder).

Up to now none of this worked and I would happy to get more ideas how to solve the problem.

  • Why are you calling latex with the full path of the tex-file? Doesn't latex beispiel02 work? – Ulrike Fischer Aug 19 '16 at 13:52
  • no, that didn't work, when I just type "latex beispiel02 it says that it cannot find the file :( should it? – ellibys Aug 19 '16 at 13:54
  • 1
    Yes it should. You seem not to be in the folder of your tex file. Are you using the command window or where else do you type? – Ulrike Fischer Aug 19 '16 at 13:56
  • 1
    You don't need to be sorry. I do find it quite good that you are trying to learn to use the command line -- that's a skill that is quite useful in latex. It helps to understand what the buttons in the editors are actually doing. – Ulrike Fischer Aug 19 '16 at 14:08
  • 1
    @UlrikeFischer Do you want to write an answer, or do we close this question as trivial/off-topic? – moewe Aug 20 '16 at 6:27
1

The problem was solved by chosing the exact directory of the folder with the files when putting the commands in the command window. Otherwise, the latex was still able to find the tex-file by naming the complete path, but biber wasn't able to find the .bib file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.