4

probably this is a easy question to answer but I'm just learning how to work with texstudio and latex. Currently I'm writing my thesis and I have to use chicago Manual Style - Notes and bibliography style. So the first citation with \footnote has to give me a full citation and the second time a shortened footnote citation. In the end I need the full bibliography printed (\printbibliography). I'm using biblatex and biber in Miktex. With the current package I have, I only get full citations in the footnotes and not a second shortened footnote... Does someone know what I'm doing wrong? Thanks in advance!

This is an example of the declaration of my packages:

\PassOptionsToPackage{english}{babel}
\documentclass[a4paper,oneside,10pt]{book}
\usepackage{multicol}
\usepackage[backend=biber,style=chicago-notes]{biblatex}
\addbibresource{../ref/mijnbibliografie.bib}
\usepackage{blindtext}
\usepackage{graphicx}
\usepackage{wrapfig}
\usepackage{lipsum}
\usepackage{float}
\usepackage{bibentry}
\usepackage[english]{babel}
\usepackage{url}
\usepackage{../LaTeX/Packages/boxedminipage/boxedminipage}
\usepackage[big, pagestyles]{../LaTeX/Packages/titlesec/titlesec}
\usepackage{wrapfig}
\usepackage{booktabs}
\usepackage{url}
\usepackage{graphicx}
\usepackage{hyperref} 
\usepackage{textcomp}
\usepackage[font=small]{caption}
\usepackage[final]{pdfpages}
\usepackage{amsmath}
6

Unless you have a very good reason not to, you should load the biblatex-chicago styles via the dedicated biblatex-chicago package. Use

\usepackage[notes,backend=biber]{biblatex-chicago}

instead of \usepackage[backend=biber,style=chicago-notes]{biblatex}.

If you load the style via its package, some options are set for you; amongst those are the options for citetracking, which are otherwise disabled by default. The options set for the note style are

  \ExecuteBibliographyOptions{%
    pagetracker=true,autocite=footnote,abbreviate=false,alldates=comp,
    citetracker=true,ibidtracker=constrict,usetranslator=true,
    usenamec=true,loccittracker=constrict,dateabbrev=false,
    maxbibnames=10,minbibnames=7,sorting=cms,sortcase=false}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.