4

Say I made the code snippet: $@$@, like the standard inline mathmode (ctrl + shift + m), but added a "dot/bullet" after the dollar sign. Can I jump from the first to the last and vice versa? When I'm trying this, upon expanding the code, the cursor automatticly jumps to the last dot. Why is this happening? Here is an example of creating a snippet with one dot. In addition I'm also wondering whether I can jump to another dot after I've started written in either of them. There is a discribing picture of the scenario in section 4.3.

Sorry if I got the tag wrong: there were non for snippet or texmaker, feel free to change it. Also, don't just downvote without giving a reason.

Thanks in advance

migrated from tex.meta.stackexchange.com Aug 20 '16 at 13:30

This question came from our discussion, support, and feature requests site for users of TeX, LaTeX, ConTeXt, and related typesetting systems.

  • What "curly bracers"? You can jump with Tab or Shift+Tab to right or left. On my test the cursor went to the first dot, not last, so I can't replicate (Texmaker 4.5 on linux). – alwaysask Aug 20 '16 at 14:38
  • @alwaysask Sorry, that was a typo, corrected now. Well I've typed the code exactly like stated and the cursor automattically jump to the last dot. Also I can't jump back and forth with Tab or shift+tab. Trying Tab just makes the cursor jump to the first dot, but trying any of those commands again doesn't make it jump back to the start dot. – Thomas Aug 20 '16 at 14:48
  • I have created the snippet precisely as in the linked YT video (to ensure reproducibility) but typed $@$@ instead of $\left( @ \right)$ => the cursor goes to the first placeholder.. Which Texmaker version on what OS are you using? – alwaysask Aug 20 '16 at 16:44
  • Yes I can see that it works for you, but now I'm really wondering why it doesn't work for me since I've written the exact samt code. I'm running Texmaker 4.4.1 on Ubuntu. The cursor jumps correctly on a different snippet e.g. \section{@}@, but I'm not able to jump back and forth if I have them on different lines. Any ideas? – Thomas Aug 20 '16 at 18:45
  • Works with Texmaker 4.4.1 (from ubuntu repos) on Ubuntu 16.04 as well. Possibly a lib or ini conflict of some sort on your machine, specially if your ubuntu or Texmaker were upgraded and not fresh installed. Try saving and backup Texmaker's settings someplace else, remove ~/.config/xm1 folder, start Texmaker and try again. Recently someone experienced an unwanted behaviour after upgrading to 16.04, probably not your case but doesn't hurt to have a look. – alwaysask Aug 20 '16 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.