2

I'm using KOMA-Script and scrreprt and I can't figure out how to reduce the whitespace on the top of my titlepage. Can somebody tell me how to do it? But only on the titlepage.

My code is as follows:

\documentclass[%
12pt,
parskip=half,
headsepline,
plainfootsepline,
footsepline,
%toc=nobib
]{scrreprt}
\usepackage[onehalfspacing]{setspace}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{vmargin}
\setmarginsrb{30mm}
        {20mm}
        {20mm}
        {20mm}
        {15pt}
        {10mm}
        {20pt}
        {10mm}
\usepackage{scrpage2}
\pagestyle{scrheadings}
\usepackage[
printonlyused,
withpage,
%footnote
]{acronym}
\usepackage{color}
\usepackage{moreverb}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage{url}
\usepackage{booktabs}
\usepackage{pdfpages}
\begin{comment}
\usepackage[%
breaklinks=true,
bookmarksopen,
%pdfstartview=FitH,
colorlinks,
%urlcolor=black,
linkcolor=black,
citecolor=black,
%pdftitle=xyz,
pdfauthor={myname}
]{hyperref} 
\end{comment}
\setlength{\headheight}{1.1\baselineskip}
\usepackage[list=false]{subcaption}
\usepackage[font=small,labelfont=bf,justification=RaggedRight,singlelinecheck=false,format=hang]{caption}
%------START BIBLATEX CONFIG ---------%
\usepackage{csquotes}           
\usepackage[%
    backend=biber,              
    texencoding=utf8,           
    bibencoding=utf8,           
    style=authoryear,           
    autocite=inline,            
    maxnames=2,                 
    maxbibnames=5,              
    firstinits=true,            
    uniquename=init             
]{biblatex}
%
% Rename Bibliography and use of "et. al."
\DefineBibliographyStrings{ngerman}{bibliography={Literatur},andothers={et al.}}
%
% Author format
\renewcommand{\mkbibnamelast}[1]{\textsc{#1}}
%
% Quote as "Author (Year)"
\makeatletter
   \def\ifEmpty#1{\def\@tmp{#1}\if\@tmp\@empty}
\makeatother
\newcommand{\citeaj}[2][]{%
   \citeauthor{#2} (\citeyear{#2}%
      \ifEmpty{#1}\else , #1\fi%
   )%
}
%
\urlstyle{sf}                   % makes BibLatex use a sans serif font for URL in references, to improve line breaking
\addbibresource{bib.bib}        % *.bib File for BibLaTex.
%
% Prevent switching author' first and last names
\DeclareNameAlias{sortname}{last-first}
%
% remove 'and' in front of last author, use comma instead
\renewcommand*{\finalnamedelim}{\multinamedelim}
%
% Colon after Year in Bib
\renewcommand{\labelnamepunct}{\addcolon\space}
%------END BIBLATEX---------------%
\setcounter{tocdepth}{2} 
\tolerance 2000
\emergencystretch 20pt
\renewcommand*\chaptermarkformat{} % don't use numbers in front of chapter titles in header
% COMMANDS FOR TITLE PAGE
\newcommand{\thisdoctitle}{}
\newcommand{\thisauthors}{}
\newcommand{\thisauthorstitle}{ }
\newcommand{\thisauthorsbirthday}{}
\newcommand{\thisauthorsmatnr}{}
\newcommand{\thisauthorsemail}{}
\newcommand{\thisdoctype}{}
\newcommand{\erstgutachtertitel}{}
\newcommand{\erstgutachtername}{}
\newcommand{\zweitgutachtertitel}{}
\newcommand{\zweitgutachtername}{}
\newcommand{\thisdoctitledate}{\today}
\newcommand{\thisdocversion}{1.0}
\newcommand{\thisdocversiondate}{\thisdoctitledate}
\newcommand{\thisdoccomment}{}
\newcommand{\copyrightdate}{\the\year}
\newcommand{\thisfooteroddpages}{\thisauthors}
\newcommand{\thisfooterevenpages}{University of ...}
%--------------------------------------------------------------
\begin{document}
% BEGIN TITLEPAGE
\automark[]{chapter}
\thispagestyle{empty} \enlargethispage{20mm}
\definecolor{mydarkgreen}{rgb}{0,0.2,0}
\begin{center}
% documentitle
\begin{spacing}{1.9}
{\color{mydarkgreen}\Huge \thisdoctitle}
\end{spacing}

\vspace{2mm}
% seal of university
\includegraphics[height=60mm, clip=]{./uni_logo_aktuell_600dpi}

\vspace{8mm}
% documenttype
{\scalebox{2}{\color{mydarkgreen}\fontsize{14pt}{0pt}\selectfont\thisdoctype}}
%{\color{mydarkgreen}\Huge\thisdoctype}

\vspace{2mm}
\begin{spacing}{0.7}
{\color{mydarkgreen}\large some text

\large \textbf{some text}}

\vspace{8mm}
% name of university
{\color{mydarkgreen}\large text text 

text text text 

text text text text 

text text }

\vspace{8mm}
% Author name, title, birthday
{\color{mydarkgreen}\large vorgelegt von

\Large\textbf{\thisauthors},~\thisauthorstitle

\large geboren am~\thisauthorsbirthday

\large Mat-Nr.:~\thisauthorsmatnr}

\vspace{8mm}
% Erst- und Zweitgutachter
{\color{mydarkgreen}\large Erstgutachter:~\erstgutachtertitel~\erstgutachtername}

{\color{mydarkgreen}\large Zweitgutachter:~\zweitgutachtertitel~\zweitgutachtername}

\vspace{8mm}
% date
{\color{mydarkgreen}\large Eingereicht am~\thisdoctitledate\rule{0mm}{0mm}}

\end{spacing}
\end{center}
% END TITLEPAGE
% --------------------------------------------------------------
\pagenumbering{roman} \setfootsepline{}[\color{white}]
\tableofcontents
\listoffigures
%--------------------------------------------------------------
% Header und Footer Definition
\pagenumbering{arabic} \setfootsepline{}[\color{black}]
\setkomafont{pageheadfoot}{\normalfont}
    \ihead[]{\headmark}
    \chead[]{}
    \ohead[]{}
    \ifoot[\thisauthors]{\thisauthors}
    \cfoot[University ...]{University ...}
    \ofoot[\pagemark]{\pagemark}

%----- BEGIN CONTENT -------%
\include{includes/01Introduction}
\printbibliography
\end{document}

Thank you.

EDIT:

This is the result when \usepackage{showframe} is added. The lines are the same throughout the whole document. It seems I need a way, to remove the header box only on the titlepage:

enter image description here

EDIT 2:

Okay, I found this question, and someone suggested using \vspace*{-2cm} to push the text up a little, which worked nicely for me.

Furthermore, it is stated, that the showframe package shows headerframes on the titlepage, even if they're not really there, which adds to the confusion:

Thank you, you are right, but because I was using showframe, I thought that the title environment has a reserved header space and I thought that I am supposed to use it, since it's there. Now I know better from @Johannes_B comment that showframe shows the frame for normal pages, even on the title page and the title page doesn't really have a any kind of header section in it, so I can simply just write some text and get it out of the text section by using a negative \vspace{-2cm} – Andrei Aug 6 '15 at 13:30

  • You use a lot of \\ for line breaks; see this question/answer. In a nutshell, don't use \\. – heather Aug 22 '16 at 19:58
  • Thanks. KOMA has a parskip setting so I think another line like the ones in the question you linked would be redundant, right? Anyway, I removed all the \\ and just made lots of paragraphs. But it doesn't solve the whitespace problem. – kett Aug 22 '16 at 20:38
  • 1
    Can you post a minimal example here? Questions should be self-contained to remain useful later. But also, lots of people won't bother to follow a link. (Like me, most of the time.) – cfr Aug 23 '16 at 1:41
  • I added the result of \usepackage{showframe}. I also found another question, which solved the problem for me. All done ;) – kett Aug 23 '16 at 9:43
  • 1
    Package vmargin is more than just a bit obsolete. geometry should be used to set the page margins. – Johannes_B Aug 24 '16 at 5:58
2

It could be there is a little missunderstanding, I guess ...

Please have a look into the documentation of KOMA-Script (texdoc scrguien or texdoc KOMA-Script) on page 58, parameter titlepage and page 59, environment titlepage.

In KOMA-Script you can use \maketitle to set a complete title (as usual) or with special KOMA-Script added pages for dedication etc (see documentation!) or you can define an own titlepage with environment titlepage like (example from KOMA-Script documentation):

\documentclass{scrbook}
\begin{document}
\begin{titlepage} % start titlepage
\textbf{\Huge Me}
\end{titlepage}   % end titlepage
\end{document}

Both of theese titlepages are set inside the usual typing area, created by KOMA-Script. In environment titlepage you can of course use commands to change margins like \vspace etc. But be sure that theese changing do only change this titlepage, not the complete document!

Usually the (hard)cover of a book is set in an own document, because the cover follows other typographic rules than the pages inside a book. Pages inside a book should respect the choosen typing area, a book cover should get the attention of a potential reader ...

In your code, based on KOMA-Script, you did not use \maketitle nor environment titlepage. I suggest you to use

\begin{titlepage}
  % \vspace{-2cm}  % if really needed ...
  % BEGIN TITLEPAGE
    % your code between both comments
  % END TITLEPAGE
\end{titlepage}

in your code. There you can use \vspace{-2cm} if really needed.

At last this all depends if you need a real book cover (best to be set in a separate document, must not be LaTeX, depends on the publisher) or titlepage(s) inside a book you did not mention.

Titlepages inside a book follows the choosed typing area of the book, to have no break of the general typography. Therefore titlepages inside books are set inside the typing area you can prove with package showframe ...

If you now use commands like \vspace{-2cm} etc. you break the chosen typography. If that is okay for you, good. If it is not (i.e. if it results in a very bad looking title page), change the design of the inside titlepage to fill only the given typing area ...

  • Thank you. I implemented \begin{titlepage} and \end{titlepage} as advised. Worked! – kett Aug 25 '16 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.