1

I am creating a presentation for defending my thesis and I needed to add the name of my supervisor to title page. I did it using code from here ... It works fine when I consider adding the plain text, but it destroys nice shape of the color frame and its shading which is under the title as default on title page of this theme. I know that by redefining the title page I somehow "turned off" these features but I would like to turn them on again since it looks good.

Here is my code (not sure whether it will work here):

\documentclass{beamer}
\mode<presentation> {
  \usetheme{Warsaw}
  %\setbeamercovered{transparent}
}

%\usepackage{ucs}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[slovak]{babel}
\usepackage{palatino}
\usepackage{graphicx}

\title{Aplikácia metódy združených asymptotických rozvojov vo finančnej matematike.}
\subtitle{Application of matched asymptotic expansions method in financial mathematics.} 
\author%[Author, Anders] % (optional, for multiple authors)
{Bc. Jozef Janočko}
\institute[Universities Here and There] % (optional)
{

  Fakulta matematiky, fyziky a informatiky\\
  Univerzita Komenského
 }

%{RNDr. Be\'{a}ta Stehl\'{i}kov\'{a}, PhD.}
%\subject{Computer Science}
\setbeamertemplate{title page}
{
  \vbox{}
  \vfill
  \begingroup
    \flushleft RNDr. Beáta Stehlíková, PhD.
    \vskip0.5em%
    \centering
    \begin{beamercolorbox}[sep=8pt,center]{title}
      \usebeamerfont{title}\inserttitle\par%
      \ifx\insertsubtitle\@empty%
      \else%
        \vskip0.25em%
        {\usebeamerfont{subtitle}\usebeamercolor[fg]{subtitle}\insertsubtitle\par}%
      \fi%     
    \end{beamercolorbox}%
    \vskip1em\par
    \begin{beamercolorbox}[sep=8pt,center]{author}
      \usebeamerfont{author}\insertauthor
    \end{beamercolorbox}
    \begin{beamercolorbox}[sep=8pt,center]{institute}
      \usebeamerfont{institute}\insertinstitute
    \end{beamercolorbox}
    \begin{beamercolorbox}[sep=8pt,center]{date}
      \usebeamerfont{date}\insertdate \\
    \end{beamercolorbox}\vskip0.5em
    {\usebeamercolor[fg]{titlegraphic}\inserttitlegraphic\par}
  \endgroup
  \vfill
} 
\begin{document}
\frame{\titlepage}


\end{document}

This is how it looks now:

Text is added

This is how it looked before:

Without added text

  • 2
    Can you post an image of the output title page to illustrate the problem? It's quite hard to follow where the issue is, but looking at the question you link to that seems to heavily redefine the title page so there may be a simpler change which has the same effect without interefering with the theme. It would also be helpful if you could provide code for a MWE – Dai Bowen Aug 24 '16 at 10:16
  • Could you please add a MWE, that includes the theme you are using? As the titlepage definitions vary from theme to theme, you have to modify the right one. – samcarter_is_at_topanswers.xyz Aug 24 '16 at 10:19
  • OK, I'll change my first post to include these. – Jozef Janočko Aug 24 '16 at 12:11
  • If there was a simper ways how to add only that one line of text I would definitely choose that one but I haven't find that option anywhere till now. – Jozef Janočko Aug 24 '16 at 12:22
1

Is this the result you are looking for?

\documentclass{beamer}
\mode<presentation> {
  \usetheme{Warsaw}
  %\setbeamercovered{transparent}
}

%\usepackage{ucs}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[slovak]{babel}
\usepackage{palatino}
\usepackage{graphicx}

\title[short version for footline]{Aplikácia metódy združených asymptotických rozvojov vo finančnej matematike.}
\subtitle{Application of matched asymptotic expansions method in financial mathematics.} 
\author%[Author, Anders] % (optional, for multiple authors)
{Bc. Jozef Janočko}
\institute[Universities Here and There] % (optional)
{

  Fakulta matematiky, fyziky a informatiky\\
  Univerzita Komenského
 }

%{RNDr. Be\'{a}ta Stehl\'{i}kov\'{a}, PhD.}
%\subject{Computer Science}
\makeatletter
\setbeamertemplate{title page}
{
    \vbox{}
    \vfill
    \begingroup
    \flushleft RNDr. Beáta Stehlíková, PhD.   % NEW
    \vskip0.5em                                                             % NEW
    \centering
    \begin{beamercolorbox}[sep=8pt,center,colsep=-4bp,rounded=true,shadow=\beamer@themerounded@shadow]{title}
        \usebeamerfont{title}\inserttitle\par%
        \ifx\insertsubtitle\@empty%
        \else%
        \vskip0.25em%
        {\usebeamerfont{subtitle}\usebeamercolor[fg]{subtitle}\insertsubtitle\par}%
        \fi%     
    \end{beamercolorbox}%
    \vskip1em\par
    \begin{beamercolorbox}[sep=8pt,center,colsep=-4bp,rounded=true,shadow=\beamer@themerounded@shadow]{author}
        \usebeamerfont{author}\insertauthor
    \end{beamercolorbox}
    \begin{beamercolorbox}[sep=8pt,center,colsep=-4bp,rounded=true,shadow=\beamer@themerounded@shadow]{institute}
        \usebeamerfont{institute}\insertinstitute
    \end{beamercolorbox}
    \begin{beamercolorbox}[sep=8pt,center,colsep=-4bp,rounded=true,shadow=\beamer@themerounded@shadow]{date}
        \usebeamerfont{date}\insertdate
    \end{beamercolorbox}\vskip0.5em
    {\usebeamercolor[fg]{titlegraphic}\inserttitlegraphic\par}
    \endgroup
    \vfill
}
\makeatother

\begin{document}
\frame{\titlepage}
\end{document}

enter image description here

  • The shading still does not work for me for some unknown reason but at least the shape is nice again. Thx very much :) – Jozef Janočko Aug 24 '16 at 14:07
  • Did you try with the exact same code from my answer? How are you compiling? I used pdflatex from texlive2016 – samcarter_is_at_topanswers.xyz Aug 24 '16 at 14:08
  • I copied just the body of \setbeamertemplate macro ... and I use pdflatex through TeXnicCenter. – Jozef Janočko Aug 24 '16 at 14:10
  • Did you also copy the \makeatletter things? Otherwise can you update your MWE? – samcarter_is_at_topanswers.xyz Aug 24 '16 at 14:11
  • No, since I want to have a beamer and not a letter. But I think this aswer is fine. I did not achieve everything but I have next 15-20 slides to do and a cannot spend days with the first one. – Jozef Janočko Aug 25 '16 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.